AV receiver update


Novice Member
I was trying to update firmware on my STR-DS1250. When I ran the update using a new sandisk usb drive formated in fat32 I was getting a message "NO SUPPORT" I tried a different USB drive, old Kingston Fat32 and with this one the update process started but got stuck at zero percent (on display UPDT 0) even if left for several hours or repeating the process. The problem is now the AV receiver is in update mode (loop) and can't be switched off. When I press the power (off) button it goes back on immediately resuming the update witch always gets stuck at zero percent. If the usb drive is removed it shows NO DEVICE on the display and the receiver does not respond to any buttons.
Last edited:


Active Member
Yup, common fault with a lot of Sony receivers. Not much you can do now. Unless someone out there knows how to un brick one.

The latest video from AVForums

AVForums Movies Podcast: We review Dune and ask which is the best decade for horror movies?
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom