• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

autofocus issues on 350D

johndow

Active Member
I have been experiencing some intermittent autofocus problems with my 350D lately. It seems to be when using the kit lens.

I tried the kit lens today and no luck. I switched back and forth from manual to auto, turned it on and off several times, but nothing. I have a 50mm prime which has hardly been out of the box, and i can remember on one occasion the autofocus wouldn't work on it for a period, and then it was fine after.

I tried the other two lens today (50mm and 55-250mm) and they were fine. i placed the kit lens back on and it was still dead.

It does make a small sudden movement which is barely noticeable when i try and focus it.

As a greenhorn and someone who doesn't want to uneccesarily tamper with the camera, can someone recommend anything i can do to rectify the problem.

P.S. The camera/ lens are all well looked after and get minimal use and can go for months without being taken out of the bag.

Thanks
JD
 

senu

Distinguished Member
Could be the lens
You lose nothing by wiping its electronic contacts with a small amount of alcohol
 

bowenjones

Well-known Member
Another way of cleaning the contacts other than using alcohol is to lightly rub them with a pencil eraser (not too hard mind as you'll get rubber bits falling into the lens).
 

johndow

Active Member
With careful use (i.e. not getting it on the lens or other bits), would it be ok to use electrical contact cleaner which evaporates off. As i have this stuff at home.

JD
 

The latest video from AVForums

Guardians of the Galaxy Xmas Special, Strange World, Bones and All, and Cabinet of Dr Caligari in 4K
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom