Auto selection of strongest wifi signal?

patrober

Active Member
Ive got a wifi router (draytek) and just setup a wireless access point (bufallo) at the other end of the house and they work fine.

Is there a way to get the laptop to select the strongest signal automatically (ie main router, or WAP) rather than just the preferred network?

Or is there a way to have them have the same SSID so that I only see one network? I tried setting them up with the same SSID but it didnt work!

Cheers!

Pat
 

t72bogie

Well-known Member
do they both connect via ethernet back to a router?

the standard for 802.11 to handover between access points on the same network, is defined to work over the ethernet backhaul

you need all APs on the network on the SAME SSID, but different channels (preferable 6 channels apart)

then when another AP becomes stronger the wi-fi adapter should change over seamlessly when a particular AP becomes stronger ...this is known as "roaming" and is how every large wireless network is designed to work
 

SeanT

Distinguished Member
Only works with open or wep level encryption though, iirc, which is why large wireless systems will use a different kind of authentication (eg. open network and web auth plus vpn above this, which is how it's done on ours)
 

t72bogie

Well-known Member
errrrr..... I think you will find thats just a limitation of your equipment and/or whoever installed it for you combined with how its set-up

WPA2 actually added even faster roaming capablities to support seamless handover for such things as wi-fi VoIP handsets ...I know this works as Ive done a lot of testing in the lab ;)

the basics for wireless LAN roaming are just SAME SSID, different channel, SAME security
 

patrober

Active Member
errrrr..... I think you will find thats just a limitation of your equipment and/or whoever installed it for you combined with how its set-up

WPA2 actually added even faster roaming capablities to support seamless handover for such things as wi-fi VoIP handsets ...I know this works as Ive done a lot of testing in the lab ;)

the basics for wireless LAN roaming are just SAME SSID, different channel, SAME security

limitation of both equipment (draytek is old) and me! I think i had them on different security thinking about it. The WAP is connected via ethernet cable to the draytek router so sounds like it should work.

I'll give it a play leter on - though probably not today as its sunny for a change so outside playing!

Cheers everyone! I'll let you know how it goes.
 

SeanT

Distinguished Member
Ah, fair enough. Just goes to show that you should never take what somebody tells you on a training course, or what you read on the net, as gospel, without trying it yourself. I switched off the access control on my three wireless APs at home just now, and gave them all the same SSID and password (on three different channels, 3, 8 and 13 due to the neighbours' APs) - now seamless across the house using WPA - all I need now is a WPA2 capable Sky router rather than the old 834....

There are usually other reasons why organisations often use unencrypted wireless and then get the client to authenticate in some other way.
 

mickevh

Distinguished Member
Roaming decisions are made by the NIC in the client, not the access points. Some NIC's will doggedly hang on to whatever AP they first associate with until they absolutely have to switch, some will continually search for the best quality signal.

Whenever you "roam" there's a loss of connection whilst roaming takes place, so depending on the applications you are running, there are pros and cons to how agressively you roam.

Many NIC's have a control called "roaming aggresiveness" or something similar so you can tune the perormance yourself.

In addition to what others have said, make sure you set up the same passphrase on both AP's. Basically, everything needs to be the same except the radio channel.

Presuming the backhaul between the two AP's if over a wired network, I'd also ttry disabling the DHCP server on one AP (router) so clients don't also have to acquire new IP address when they roam.
 

SeanT

Distinguished Member
You should only really have one (active) dhcp server on your network, unless there's a compelling reason to have another one (other than the failover one)
 

patrober

Active Member
right - finally got around to trying it - setup both to be on WEP with same SSID and password. Switched off the DHCP server on the WAP and .... it doesnt work.

The PC connects to the original network (ie via the draytek router) fine and sees the internet. But if i roam to to hte bufallo WAP it looks like the PC switches to the WAP (as the status changes to Access: local only) but I cant connect to any web page - not even the setup up web page for the WAP.

Any thoughts?

If i connect the pc to the WAP via ethernet cable rather than Wifi then it works fine.

[edit] forgot to say - one odd thing is that with hte ethernet cable connected, and i try and renew the IP address it times out. Oh and the channel numbers are 1 and 11 so that shouldnt be an issue.

Cheers!

P
 
Last edited:

mickevh

Distinguished Member
How are the two AP's connected to each other? (Ethernet cable, wifi bridge, something else..?)
 
Last edited:

patrober

Active Member
How are the two AP's connected to each other? (Ethernet cable, wifi bridge, something else..?)

hi

the draytek is the router (ie connected to the phone line) and the bufallo WAP is connected to this via an ethernet cable.

P
 

patrober

Active Member
did a little more experimenting and im sure its a dhcp/IP addressing problem. If i roam from the draytek (which has wifi internet working) to the bufallo WAP it looks like it connects to the WAP but it wont work at all (ie no internet, or even local to the WAP config web page).

But if i disconnect from the network, and reconnect again it works fine (this was with the DHCP server running on the WAP).

If i switch off the WAP DHCP server it does the same as the situation above but doesnt work if i disconnect/connect the network (ie same behaviour as before)

Is there anything i need to set on the WAP or the server to say its theres a bridge to enable the draytek dhcp server to work across both the draytek and the WAP?
 

mickevh

Distinguished Member
To rule in/out DHCP issues, try temporarily setting your PC to a static IP address.

Go to wherever you get a good connection,connect, open a CMD prompt and run an IPCONFIG /ALL command. Make a note of the IP Address, Subnet mask, Default gateway and DNS server addresses. Then go into the properties of your wireless NIC-TCP/IP and enter the information manually.

The try disconnecting & connecting to both AP's and see what works.

Also, Windows maintains a kind of list of "profiles" for every AP it connects to (again in the properties of the wifi NIC.) You could try deleting these and let it find them all again from scratch. (Sometimes it gets confused.)
 

patrober

Active Member
cheers will try the static ip route. One thought i had about this is that the 2 boxes have differerent IP address ranges (one is from 192.128.1.10 and the other is 192.128.11.1) so wonder if that is messing it up (even though I switch off hte dhcp server)

I had done the profile bit - tried starting from scratch but that didnt work.

Fun and games!

P
 

mickevh

Distinguished Member
That being the case, use a static IP address (on the PC) from the range served by your primary router - ie the one connected to the Internet.

IP addressing can cause all sorts of problems if not done right, hence the recomendation to disable the DHCP server on the second AP. The DHCP server in your second AP would be serving out IP leases which are crafted based on the presumption that that (2nd) router was your sole router and connected to the internet. But since your (2nd) router isn't connected to the internet, those leases fail, (in the sense that you don't get a connection to anything because they contain the wrong addresssing.)

There are a couple of ways to get around this, but the easiest is to not use the 2nd router to do any "routing," or other IP functions, but use it solely to provide a "bridge" between wired and wireless networks.

By disabling DHCP on AP2, when your clients send out a "can I have an IP address" requests, AP2 should forward the request on to AP1 and AP1's DHCP server should respond with a correctly crafted lease to get IP traffic flowing through AP1. AP2's DHCP obviously will not respond to the request if it is disabled.

There are still a few things that can go wrong depending on which ports you've used to cable AP2 to AP1, (for example, you should normally use a "edge" port on both not "WAN" or "uplink" port, esp on AP2.) Testing with static IP addresses will help diagnose that.
 
Last edited:

patrober

Active Member
There are still a few things that can go wrong depending on which ports you've used to cable AP2 to AP1, (for example, you should normally use a "edge" port on both not "WAN" or "uplink" port, esp on AP2.) Testing with static IP addresses will help diagnose that.

by edge port i presume you mean either port 1 or port 4 (both APs have 4 ports)

Currently the connection on AP1 is port2, and AP2 is port1. I'll try swapping that around as well so they are both on port 1. I didnt realise that would have made any difference.

Computers eh!

Cheers!

P
 

mickevh

Distinguished Member
Yes. Though from your description, it sounds like it should be good to go as it is.

Testing using a static IP address on the client will help diagnose whether you've got some issue with wifi association, authentication, etc or whether it's an IP issue.
 

patrober

Active Member
Phew. Its working! It still needs some work but it works now! Tried fixed IP address and that worked but also swapped the cable ports around as well at hte same time.

So the final solution that was missing was-

switch off DHCP
Force WAP to be in bridge mode (rather than assume AUTO works)
Change IP address of WAP to be in range of main router
swap ethernet cable to be on port 1 of main router

Its still not perfect as now I cant log onto the Buffallo WAP setup web page so need to investigate that. Also need to see if I can get it to work in a more secure method other than WEP. Im not sure on the latter as the router and WAP seem to have different names for the other modes.

Anyway - thanks to everyone for their help getting this problem solved. I may post more questions about the different security modes!

Cheers!

P
 
Last edited:

The latest video from AVForums

Samsung QN800B 8K TV Review
Subscribe to our YouTube channel

Full fat HDMI teeshirts

Support AVForums with Patreon

Top Bottom