• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

Aureon 7.1 with DTS passthrough

fezster

Active Member
Following on from my thread about the Trust 511, I went out and bought an Aureon 7.1 because I didnt want the hassle of having to worry about what is or isnt encoding to Dolby Digital - I just want it to work.

One thing I found, is that setting the Aureon to SPDIF / PCM output, you can use AC3Filter to encode to Dolby Digital for you. I.e. this is what I was trying to achieve with the Trust 511, but it simply wouldnt work. I did find though that with this method, the sound would occasionally stutter, probably due to increased CPU load (need to do more testing) ? I then turned off the AC3Filter encoder, and instead set the Aureon's control panel to output in Dolby Digital, and it's all very smooth and works well (finally !) :D

I have a question about DTS soundtracks though. I refer specifically to MPEG transport streams (and possibly AVIs), rather than playing a DVD (which ive not tried yet). The sound works perfectly, but it's output in Dolby Digital. Ive tried a combination of AC3Filter as above (with passthrough options enabled), and turning the Terratec control panel output to PCM and DD. But either I get stereo output or I get DD output. I can't seem to get DTS to passthrough to the amp. Is it even possible ? Or does this only work with DVDs ?

Thanks.
 

mannyo

Active Member
I am hazzarding a guess here, I use AC3filter and passthrough DTS and DD to my AV amp successfully as intended, I think you may have a codec issue. I went through a simillar hair pulling excersize until I realised that AC3filter wasnt being used even though it thought it was. Uninstalled every codec from my machine as its MCE only, and got it working. The only codecs on my MCE system now are Purevideo decoder, Divx and AC3Filter. I deregistered the nvidia audio filter so AC3filter is used for everything. In the AC3filter control panel, enable SPDIF output and on the system tab tick passthrough for everything except Mpeg.
 

fezster

Active Member
I tried removing the CCCP (Combined Community Codec Pack) and unregistered the Nvidia audio decoder. AC3Filter was definitely being used as it's icon was appearing when starting the movie, and messing with the settings was having an impact on output.

What I found was that if I unticked AC3 passthrough, then it would output in PCM. And ticking it in DD. So it seems as if the movie has an AC3 soundtrack as opposed to DTS. But I know for a fact that when I play this movie through my Snazio, it shows as a DTS sound stream on my amp. I also checked the .ts file to see if there were 2 audio streams, but it seems there isnt.

Im confused - im sure there's a rational explanation but it eludes me. Perhaps there is a codec on my machine which is showing the DTS stream as an AC3 stream ..... at this point, Im just glad it's outputting in surround sound. I think I'll leave it at that.
 

fezster

Active Member
It works ! Tried gladiator with an external DTS soundtrack in Media Player Classic. I found I had to disable ffdshow for AC3 and DTS, so that AC3Filter was used (even though it seemed as if it was being used before).

Only problem now is that MCE does not allow external audio tracks.
 

The latest video from AVForums

Guardians of the Galaxy Xmas Special, Strange World, Bones and All, and Cabinet of Dr Caligari in 4K
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom