Audio out options on a Sky Plus box

Bert Coules

Well-known Member
I'm using a Sky Plus box through a Marantz AV amp via HDMI. I was hoping to take a separate feed of audio only from the Sky box's optical socket but it doesn't appear to be carrying a signal. Does using HDMI kill the optical out? Or is there a software switch option that I'm overlooking?

Many thanks.
.
 

SteveU30

Distinguished Member
If there’s a setting anywhere it’ll be on the Marantz as you’re giving it two feeds from the same source and it’ll probably choose HDMI every time unless you override it.

Can I ask why you want to do this though? What are you trying to achieve?
 

noiseboy72

Distinguished Member
The optical output follows the HDMI in terms of format, so if you are outputting Dolby Digital via the HDMI, you will get the same from the optical output. This might be an issue if you wanted PCM 2.0 to feed into a stereo amp or similar.
 

Bert Coules

Well-known Member
Thanks for the speedy replies. SteveU30, the separate audio feed is to a different amp, not the Marantz. Noiseboy72, thanks for that: I am indeed outputting Dolby Digital on HDMI; I'll check whether or not the separate amp can handle that or needs PCM.
.
 

JayCee

Distinguished Member
The optical output follows the HDMI in terms of format, so if you are outputting Dolby Digital via the HDMI, you will get the same from the optical output. This might be an issue if you wanted PCM 2.0 to feed into a stereo amp or similar.
Nope, on a Sky+HD box both HDMI & Optical are independently selectable so you can have Dolby D via HDMI but Stereo (or “Normal” as labelled by Sky) via Optical.
 

Mike Hughes

Active Member
Resurrecting this to see if someone can help.

Having issue with my Naim kit (whole other story) so trying to get sound from the optical out on a Sky Plus to go via a Schitt Modi 3 DAC into my 202. Total silence. Picture and sound normally go from Sky Plus to TV via HDMI.

So, how do I get this to work?
 

JayCee

Distinguished Member
Go into the Sky box sound settings and toggle optical out from “Dolby D” to “Normal” and save the setting by pressing the green button.
 

JayCee

Distinguished Member
You need to try feeding the output from the DAC into something else like an amp or headphones to check it's outputting.
 

The latest video from AVForums

Podcast: Reported HDMI 2.1 bugs, Audiolab Amp & LG LED Projector reviews + Best of the Month
Top Bottom