ATI to Nvidia upgrade, now MCE is poked. Help!

pmc

Active Member
Not sure if this should be in the MCE or the hardware subforums so I'll just put it here :)

I'm running MCE and recently changed my graphics card from an ATI X300SE to a Nvidia 6200TC in order to get the full benefits of the PureVideo codec. It works really well with DVD's. Using Theatertek with it's built in PureVideo I have now abandoned my ffdshow quest as I can get as good a picture with PureVideo without the processor overhead.

However I am having serious problems with MCE. TV recording played back via MCE now look terrible! Really blocky and blurry. Peoples faces almost seem to become 'detached'. for example if they move their head their forehead can seem to be a fraction of a second behind the rest of the head. There is also loads of ghosting and colour bleed on movement, and blockiness on large areas of colour. Basically I seem to have every mpeg artifact there is, it just looks terrible.

My thought is that MCE is confused by the change of graphics cards and is using the wrong codec, or not using Purevideo properly. In order to get the best possible picture on DVD's I set the sharpening and noise reduction on PureVideo up to about 70%. DVD's look great but TV inside MCE is unwatchable. Setting these settings back to 0% improves it a lot but it's still really bad. This implies that MCE is at least using PureVideo, just not very well. Interestingly MCE recording look fine when played with Theatertek.

I have my HTPC hooked up to SD CRT via Svideo and a HD PJ via DVI running at 720p. The picture is much worse on the TV. The problems still occur on PJ though. One thought I had was that something is wrong with the deinterlacing but that would only affeact the PJ right? The TV has an interlaced signal so wouldn't be affected, or is that completely wrong?

I have calibrated both displays. The PJ with THX optimiser and the TV with the MCE optimiser. That seemed to help a bit but it's still not right.

So this imples something is wrong with how MCE is using the PureVideo codec. How can I fix this? One possibility is that MCE isn't actually using the PureVideo codec that comes with Theatertek, but if so why does changing the settings have an effect. Another thought is that when MCE was installed it detected the ATI card and set itself up appropriately, now the Nvidia card is causing problems. Could this be the case? How do I get it to reconfigure itself to work with the Nvidia hardware and software?

Any suggestions would be greately welcomed, I've been banging my head against a wall on this for days.

As a side question, does anyone know how to force a particular codec to be used? i.e. how do you change the video path?
 
Well I never likd them Nvidia Cards, I use Win DVD 7, and it gives a great picture, why not uninstall Theatrek and any other mpeg 2 decoders and try out Win DVD 7, it does not use Purevideo so you should be able to work out where the problem lies...going form an X300 to a 6200 is like going form a 17" sharp LCd to 17" samsung LCD no difference really, forget all the purevideo stuff, I hear the x300 is pretty crappy anyway for MCE, get hold of an X1300 PRO and WinDVD7....
 

pmc

Active Member
The PureVideo codec is great for post processing video. As I say it's negated the need for ffsdhow for me. Getting rid of it is not really an option ;)
 

Bl4ckGryph0n

Distinguished Member
I am thinking version numbers conflicts.....What purevideo version are you using and what nvidia driver version are you using....

Did you redo the MCE/Settings/TV/Configure your display wizard? And set all the connections appropriately? Also have you set the correct resolution in the nVidia control panel, and the correct refresh rate and applied the refresh rate hack in MCE?
 

pmc

Active Member
Thanks for the suggestions.

I have set the graphics card up in clone mode. The primary display is 720p/50Hz over DVI. The clone display is over SVideo and set to 720x568/50Hz and I/PAL. I redid the set up in MCE. This helped a little.

It's happening on both displays.

I didn't know about the refresh hack. I'll try that tonight. I do get jerkiness in the picture and this may fix that, cheers.

The big problem is the blockiness and colour bleed that's going on. It's like watching a really badly compressed video. Lots of things make it better, reducing the colour on the graphics card, turning off sharpening and noise reduction in PureVideo, redoing the set up in MCE. All help but it's still really bad.

I'll check the version numbers tonight. The codec comes with Theatertek 2.4 which is a couple of months old and the drivers are the latest ones. I wouldn't have thought they would be a problem that close together but you never know.

I downloaded a utility from Microsoft that shows which codes MCE is using. It definitely thinks its PureVideo.
 

Bl4ckGryph0n

Distinguished Member
If you are running the latest nVidia drivers, 91.xx or something like that, I would return to the 84.xx or even 81.xx or even 79.xx drivers and choose the MCE versions....Install and reboot....Also I would try and get it to work properly on one screen before getting into cloning etc....

As a side note, shouldn't the s-video pal screen be 720x576?
 
Top Bottom