Asustor Plex Nightmare - Help Needed

sagaris99

Well-known Member
Asustor AS6604T 4 bay, all set up fine.

I'm trying (and failing) to enable the Asustor as a Plex Server.

For some reason, whenever I get to the stage of assigning the plex app on the server to see it's own folders, it refuses to.

So
1. Installed Plex from Asustor App Store (as well as downloading Asustor apk from Plex and Manually Installing, no difference)
2. Create new Plex Account
3. Click on 'Your Media' - As you can see in the image Plex1, the only option I have is to 'download our free Plex Media Server software on the device where you store your media.'
4. If I click on the 'Get Plex Media Server' button, I'm redirected to Media Server Downloads | Plex Media Server for Windows, Mac, Linux, FreeBSD and More where I can either download Plex for Windows (which I've done and it makes my current PC the server), or I can redownload the Asustor apk again, stuck in a loop.

I'm at a total loss.

I have a folder on the NAS called 'MOVIES', full of all the files I want to play on Plex, but the app refuses to see them, or any media on the NAS.
I can see the install of Plex created a Plex folder in the directory, with sub folders in it - see second image.

I've attempted to manually add the Plex Server on a TV App, installed Plex, logged in, manually added the server IP Address and Port, but still nothing.

Any ideas? I'm really frustrated, this was the main reason I upgraded the NAS and Plex/Asustor support is as much use as a chocolate teapot.

Is there a setting on the Asustor to enable it to be visible to the network? I've mapped shared drives already, no problem there.

Cheers
 

Attachments

  • Plex1.png
    Plex1.png
    763.5 KB · Views: 41
  • Plex2.png
    Plex2.png
    37.4 KB · Views: 34
Last edited:

next010

Distinguished Member
On QNAP NAS you must go into the shared folder permissions after installing Plex and give the plex user account it created read permissions over the folders.

See if there is a plex user account on your shared folder permissions.
 

sagaris99

Well-known Member
are you manually installing plex by downloading to pc then go to app central then management then manual install
Yes, manually installed it by downloading the apk from Plex, then app central, management, manual then upload
 

sagaris99

Well-known Member
have you added your movie folder to the library folder that's where go I have asustor as5304t
Yes, but there's no clear folder to put these in, so I've put it under the plex, plex library folder
 

sagaris99

Well-known Member
On QNAP NAS you must go into the shared folder permissions after installing Plex and give the plex user account it created read permissions over the folders.

See if there is a plex user account on your shared folder permissions.
Yep, double checked that Plex has read and write permissions for the entire NAS
 

sagaris99

Well-known Member
why is your movie folder not showing in picture 2 if you put it in library folder
Took the snapshot before I put it in

I've managed to make TwonkyMedia work for now, does the same job just not a user friendly as plex.
 

next010

Distinguished Member
Wouldn't hurt to try a reboot of the NAS just in case, something with the plex user account needs resetting.

Also Plex alternatives like Emby and Jellyfin are available on the Asustor in its app central.
 

Pavey

Well-known Member
It's not an answer to your problem but i've always found the Plex forum useful when stuck. One of the Plex operatives reply pretty quickly to your post.
 

sagaris99

Well-known Member
It's not an answer to your problem but i've always found the Plex forum useful when stuck. One of the Plex operatives reply pretty quickly to your post.
I'll give that a go, hopefully they don't blame it on the NAS!
 

The latest video from AVForums

Samsung S95B QD-OLED Review - A Quantum Leap for OLED!
Subscribe to our YouTube channel

Full fat HDMI teeshirts

Support AVForums with Patreon

Top Bottom