Astro A40 + Mixamp Gen4 setup PS5 (Using TV Optical Out)

loftie12

Novice Member
New A40s + Mixamp Gen4 all set up for my PS5 last night.

I've set everything up as directed (using TV optical as apposed to buying the adapter) but in Dolby mode on the mix amp nearly everything sounds echoed?
I say nearly as when testing on warzone (main reason I got them) in game menu, moving across or selecting different menus there is an echo, my character footsteps, weapon reload and other direct sounds are echoed, yet sounds around me (air strikes, ambient sounds) seem to sound fine?



My Samsung TV settings are as follows:

Select speaker = Audio Out/Optical

HDMI Audio Format = Bitstream (options are PCM or Bitstream)

Audio Format = Dolby Digital (options are PCM, Dolby Digital or DTS Neo 2:5)

(HDMI cables and optical cable are all connected to what is called a SAMSUNG ONE BOX which then has a cable which connects to the TV)


PS5 settings are:

Output device = USB Headset (Astro Mixamp pro)

HDMI device = AV amplifier

Number of channels = 5.1

Output to headphones = chat audio

Audio format (priority) = Dolby




NOTE: 3D Audio on or off makes no difference.

Any help as to why it's echoing?
 

OllieWHU

Novice Member
New A40s + Mixamp Gen4 all set up for my PS5 last night.

I've set everything up as directed (using TV optical as apposed to buying the adapter) but in Dolby mode on the mix amp nearly everything sounds echoed?
I say nearly as when testing on warzone (main reason I got them) in game menu, moving across or selecting different menus there is an echo, my character footsteps, weapon reload and other direct sounds are echoed, yet sounds around me (air strikes, ambient sounds) seem to sound fine?



My Samsung TV settings are as follows:

Select speaker = Audio Out/Optical

HDMI Audio Format = Bitstream (options are PCM or Bitstream)

Audio Format = Dolby Digital (options are PCM, Dolby Digital or DTS Neo 2:5)

(HDMI cables and optical cable are all connected to what is called a SAMSUNG ONE BOX which then has a cable which connects to the TV)


PS5 settings are:

Output device = USB Headset (Astro Mixamp pro)

HDMI device = AV amplifier

Number of channels = 5.1

Output to headphones = chat audio

Audio format (priority) = Dolby




NOTE: 3D Audio on or off makes no difference.

Any help as to why it's echoing?
Exactly the same thing happening to me literally!! Have you had any luck in sorting it by any chance?
 

loftie12

Novice Member
Exactly the same thing happening to me literally!! Have you had any luck in sorting it by any chance?

So I ended up buying the adapter to see if it made any difference. Only difference it made was removing the audio delay that I was experiencing (which I didn't even notice the delay at first!) So I've actually kept the adapter.

The sound quality is EXACTLY the same so I'm just thinking this is how it's meant to sound as I have ruled out any kind of audio compression when passing the audio through the TV, and I guess I'm just not used to dolby surround on a headset.

Warzone - first thoughts were that it's an echo, but I have persevered, I also made a EQ preset that I found from a guy on YouTube and to be honest... The directional precision for footsteps and chutes opening is crazy. I don't even notice an echo anymore.

Destiny 2 - it sounds perfect on any EQ settings.


So my advice: stick with them, set up some EQs and you'll get used to it.
 

OllieWHU

Novice Member
Thanks for replying mate, my mates thought i was going crazy when i said about the slight audio delay! I would see a bullet fly past me before hearing it and was driving me mad! I ended up unplugging the optical cable and playing with the amp usb connection only. Never had any problem with my ps4 pro, never been so frustrated trying to get a good sound since my ps5 came and trying to play warzone! I think i will order the adapter and go from there, especially if it cured your audio delay.
 

loftie12

Novice Member
Thanks for replying mate, my mates thought i was going crazy when i said about the slight audio delay! I would see a bullet fly past me before hearing it and was driving me mad! I ended up unplugging the optical cable and playing with the amp usb connection only. Never had any problem with my ps4 pro, never been so frustrated trying to get a good sound since my ps5 came and trying to play warzone! I think i will order the adapter and go from there, especially if it cured your audio delay.

Yeah I had an option on my TV to reduce the delay but even at 0, when I fired my gun it wasn't until the second bullet that i heard the first bullet fire. Annoying that you have to spend a further £35 for a £250 headset to work, but it is worth it in the long run. Baffles me why Sony opted to remove the optical port on the PS5.
Here's the link to the YouTube video for the EQ.


My only gripe is that the air strike sounds can be a little overpowering if your trying to listen for footsteps sometimes, but other that that, you can pin point footsteps etc and get the upper hand.
 

Mallett94

Distinguished Member
Thanks for replying mate, my mates thought i was going crazy when i said about the slight audio delay! I would see a bullet fly past me before hearing it and was driving me mad! I ended up unplugging the optical cable and playing with the amp usb connection only. Never had any problem with my ps4 pro, never been so frustrated trying to get a good sound since my ps5 came and trying to play warzone! I think i will order the adapter and go from there, especially if it cured your audio delay.
If you are trying a direct USB connection from PS5 to Mixamp for both game and chat audio, then make sure you have DISABLED the Dolby Headphone button on the mixamp and then rely ONLY on the 3D Audio being enabled on the PS5 for your headphone output, or just plug the a40s directly into the PS5 controller with 3d audio enabled for headphone output.
 

The latest video from AVForums

AVForums Movies Podcast: We review Dune and ask which is the best decade for horror movies?
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom