Arcam radio not storing preset stations

Discussion in 'Hi-Fi Stereo Systems & Separates' started by Bobby Silver, Feb 24, 2014.

Tags:
  1. Bobby Silver

    Bobby Silver
    Novice Member

    Joined:
    Feb 24, 2014
    Messages:
    2
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I have lots of arcam gear, but my tuner is an old arcam 8 tuner, which still gives great sound and i love it.

    However, it loses the stored radio station presets I have stored in it.

    When I store some stations it remembers them whilst I am using it, but if I power down, it fails to remember them when I turn it back on.

    I am reasonably familiar with circuit boards etc and I thought there must be
    an internal battery inside that helps hold the charge. A bit like a computer
    etc.

    However I couldn't see a battery inside to replace so I am guessing it must
    hold the station presets in memory some other way.

    Please can someone advise on what I need to do to fix this. Is it a certain
    capacitor that needs replacing or something else?.

    If anyone has any ideas please let me know. It isn't worth sending in for repair and I would
    actually like to fix it myself at my own risk.

    Many thanks,
    Bobby
     
  2. spl23

    spl23
    Well-known Member

    Joined:
    Jan 9, 2004
    Messages:
    2,672
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    103
    Ratings:
    +385
    It might just be using a large capacitor to maintain the preset memory - I've seen devices that do that. Are there any likely-looking big electrolytics in there, other than in the power supply itself? If there are any large electrolytics on the main board, I'd be inclined to investigate those...
     
  3. Bobby Silver

    Bobby Silver
    Novice Member

    Joined:
    Feb 24, 2014
    Messages:
    2
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Thanks for the reply. Appreciate it.

    Nothing is obvious. No large items which seem to stand out.

    I wonder if it is just one of the normal capsacitors etc. However, I can't find any circuit diagrams anywhere.

    Can anyone else shed any light on this. I have sent an email to Arcam but no reply whatsoever. They used to be quite good at replying to queries, but I guess they can't be bothered as it is an old machine....:-(
     
  4. ANDY_DUTTON

    ANDY_DUTTON
    Active Member

    Joined:
    Aug 27, 2002
    Messages:
    498
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    28
    Location:
    Cambridge
    Ratings:
    +87
    Hi, the part you are looking for is C84, it is a wet plate capacitor of 0.1F at 5.5V. They dry out over time so it is fairly common for them to fail after several years.

    Something like this will do the job:-
    Buy Electric Double Layer Capacitors Panasonic 0.1F -20 to +80% 5.5V dc Through Hole Electric Double Layer Capacitor Panasonic EECF5R5U104 online from RS for next day delivery.

    I can guarantee this actual part will fit the holes in the board but if you could probably make the connection with some short bits of wire (<1cm) and it would be OK.

    Regards,
    Andrew
     

Share This Page

Loading...