• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

Arcam P85 Chassis Problem

Barsby

Standard Member
Hi all,

I am hoping someone could help me with a problem I have with an Arcam P85 Power Amplifier:

The metal plate held over the heat sink which is bolted down to the chassis is the general location of the problem.

One bolt holding down the plate is not currently connected to the chassis, this is because the 'captive nut/threaded socket' on the chassis has been previously sheared off (by over-tightening at a guess). I am therefore trying to find a new 'captive nut/threaded socket' (Excuse my lame explanation of the part, I have no idea what its called) to fix back onto the chassis.

It looks like it is 'peened' to the chassis in two places and therefore I am guessing I can re-fix a new one on.

I will try and take a photo tonight to post up, but hopefully someone could help me with:

A) a name for the part!!! so I can at least search the net.
B) A possible supplier.

I have contacted arcam who replied saying they outsourced the chassis fabrication and therefore do not have the part. I have replied asking for supplier info, however I await a response and am guessing a response may not provide me with the information, as Arcam may not wish to disclose this for commercial reasons.

The amp is still running fine, however if I do upgrade in the future, I may wish to sell the amp for a decent price (hence needing fixing). PLus I find it very frustrating know its broken.
 

larkone

Distinguished Member

The latest video from AVForums

Fidelity in Motion's David Mackenzie talks about his work on disc encoding & the future of Blu-ray
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom