Arcam I am not impressed :-(

Damian1978

Well-known Member
Hi all,

Had a couple of issues recently with my DV137. It's 13 months old and won't play 2 out of the 5 SACDs I own. Only see's the CD layer. The discs are Goldfrapp's Supernature and a Bjork album (forgotten the title).

It's now taking longer to read the odd DVD and has broken up with the odd title. CD's play perfectly as do DVD-Rs.

I have an Allsopp Carbonedge laser lens cleaner which I use occasionally and have the DVD one on order as I believe it's a dual laser mechanism?? Any ideas?

So annoying. Take good care of the player and all my discs. Could it just be a dirty lens???

Also, reset the player and before I reset it it said Player Settings Invalid above the reset option you get when typing 4792. Any clues? Had a play about and now it says Player Settings Valid.

It also played one of the SACDs fine this morning after the player had been unplugged all evening.

Are SACDs read by the DVD lens??
 

adprom

Active Member
Could well be the laser assembly that has packed up.

Definitely get in touch with your dealer who can get it back to arcam.
 

spl23

Well-known Member
I suspect the cause of the problem could well be the Allsop lens cleaner, particularly if it is one designed for CD players. The optics on a DVD / SACD cleaner require much finer tolerances than CD to work properly, and they aren't designed to cope with being bashed into with brushes spinning at a few hundred RPM. Your problems could well have been caused by using it, I'm afraid, and I suspect Arcam's sympathy might be limited.

The only safe way to clean a CD / DVD lens is to take the player apart and clean it (very carefully) by hand. Unless the player shares a house with a smoker or something similar, you really shouldn't need to clean the lens on a CD / DVD player any more often than once every few years.
 
Last edited:

westcoastman

Standard Member
Hi all,

Had a couple of issues recently with my DV137. It's 13 months old and won't play 2 out of the 5 SACDs I own. Only see's the CD layer. The discs are Goldfrapp's Supernature and a Bjork album (forgotten the title).

It's now taking longer to read the odd DVD and has broken up with the odd title. CD's play perfectly as do DVD-Rs.

I have an Allsopp Carbonedge laser lens cleaner which I use occasionally and have the DVD one on order as I believe it's a dual laser mechanism?? Any ideas?

So annoying. Take good care of the player and all my discs. Could it just be a dirty lens???

Also, reset the player and before I reset it it said Player Settings Invalid above the reset option you get when typing 4792. Any clues? Had a play about and now it says Player Settings Valid.

It also played one of the SACDs fine this morning after the player had been unplugged all evening.

Are SACDs read by the DVD lens??

Had the same issue with mine, initially played all SACDs then only 2 of 5 worked. Eventually the unit was replaced and all is well now.
 

Mark.Yudkin

Distinguished Member
Sounds like a problem with the laser tracking. There's no need to get annoyed as such things unfortunately happen, and is why you get a decent guarantee.

Since you have a 2 year warranty (3 years in some countries) and the player is only 13 months old, just take it in under guarantee and the problem should be fixed. (My DV137 has no problems playing SACDs).
 

mcsdan

Active Member
I had a DV137 when they first came out and went through 3 of them before getting one that consistently worked. First 2 only lasted about 30 mins!!

Take it back to your dealer and they'll sort it out under the warranty.
 

JUS

Well-known Member
So how did you get on Damian?

I had a similar problem with a different player and a lens cleaner did the job for me.
 

Damian1978

Well-known Member
Didn't make a difference. The player is fine for the first 20 or 30mins on discs it then either doesn't detect as SACDs or then begins to struggle with certain pressed DVD's. Don't think it's a lens issue maybe a tracking issue??

Fine with DVD-Rs too :confused:
 

eponies54

Standard Member
What about another alternative?
My DV137 is some years old and I upgraded to V5.06 but did not use it for some time. When I did finally use it it had problems of Bad Disk errors and sometimes only reading 3 out of 14 tracks on CD. After reading crustyloafs firmware page, I decided to downgrade to V4.12 - all is well again!
Could your new DV137 have V5.06 and could the downgrade to V4.12 assist - done under warranty? Possibly a call to Arcam might be in order to ask this specific question?
Regards, eponies54
 

Damian1978

Well-known Member
I've been running 5.06 with no real issues since September 2008 when I got it. Did try 4.12 out of curiousity the other day. Didn't really help sadly :mad:
 

Ian_S

Distinguished Member
Whilst it's clearly a pain when things break, it happens, my FMJ C31 broke quite quickly, and also my AVP700 suffered the common diode issue. However, if the unit's under guarantee then just send it back to Arcam and get it repaired. The better warranty is part of what you pay for. I'm sure a local Arcam dealer will send it back for you.
 

The latest video from AVForums

Star Wars Andor, Woman King, more Star Trek 4K, Rings of Power & the latest TV, movies & 4K releases
Subscribe to our YouTube channel

Full fat HDMI teeshirts

Support AVForums with Patreon

Top Bottom