Arcam DV89

chris

Prominent Member
Joined
Nov 20, 2000
Messages
1,235
Reaction score
29
Points
270
Location
romney marsh, kent, uk
Has anyone that uses this player, found any probs with playing disk's.
Mine is just over a week old and has firmware 4.18.0 LT78 and so far i have found probs with 4 disks.
Toy Story 2 R1.
Close Encounters R4.
Star Was 2-ATOTC R2.
Brum R2 (kids DVD).

Anyone found probs with these.......????
Or any other disk's.
Or maybe prob's with disk's played on the DV88 that i might have and could try.
I'm takeing it back in the morning and ganner try it against the one in the shop and also see if they get the same prob's with their disk's, but would like to know of any other prob disk's i could try, so i can take them with me.
 
I will give Star Wars 2 a go and see if there are any problems. Does it happen at any particular part? I am still on drive firmware version LT76 so it may be an issue with the newer firmware on your player although it is very unlikely as Arcam are usually very thorough before realeasing new software and firmware.
 
Chris

Not in front of my player at the moment, but I have watched Star Wars AOTC Region 2 all the way through in the past without any problems - in fact as I remember it's the first movie I spun up whan I got my 89. As fo the others haven't got any of them. When I'm back home will watch it again (any excuse ;) )
 
Originally posted by Crustyloafer
I will give Star Wars 2 a go and see if there are any problems. Does it happen at any particular part? I am still on drive firmware version LT76 so it may be an issue with the newer firmware on your player although it is very unlikely as Arcam are usually very thorough before realeasing new software and firmware.

Chapter 28 Asteroid chase is where it really starts to get bad, seems to clear itself after this chapter.
Should find out in the morning thow, weather it is my disks or the player..........
hope it is the player, as that is still under warrenty.

Thing is thow, i have played (errrr...or should i say kid...:zonked: ) brum 3 times today and am playing it now, trying to find the exact place that it screw's up.
But the 3rd time i played it, it did not seem to freeze....so waiting to see what happens this time.
 
well finished playing brum for the 4th time and it screwed up a total of 0.......thats Zero times.
Tried AOTC and its still messing up in chapter 28, tried replaying the chapter 3/4 times and it messed up at different times and for different lenghts of time each go.
Have now got toy story 2 on and it has not messed about once yet, where it did yesterday.
Think i might try Close Encounters before i goto bed.
This is strange.....could it be a strange running in prob........???
 
Still sounds like firmware problems. I have not had any issues with mine at all.
 
well i've been back to the dealers and i never evern got to put my player inline and show them.
They had a DV78 set up and i tried my disk's in that and the same thing happened.
Put their copy of AOTC on and it was OK.
So it would seem that my disk's are bad.
Cannot think why thow.
I have only played Close Encounters once or twice from new and that's screwed and AOTC about three or four times from new and that is screwed.
Their copy get's played about 5 times a week........not all the way through thow, but still get's handled more than mine, but their's is OK..........:confused:
 

The latest video from AVForums

LG G4 OLED Best Picture Settings Out Of The Box - Filmmaker Mode!
Subscribe to our YouTube channel
Back
Top Bottom