Arcam AVR390 Help!


Novice Member
I am a tech and have been in this industry for almost 20 years. I decided to update my arcam 390 and update locked up and I waited 24 hours before I tried anything. It stopped on net please wait.... I tried pressing buttons on the front but to no luck. So I turned off and factory reset per instructions. No sound out of anything. Any help or ideas I would be open for. We aren’t arcam dealers but I love the sound of this product. Thanks in advance.


Novice Member
Well it turned out to be a corrupt firmware file I guess. Either that or it didn't like the brand of usb stick I used. Praise the lord I have sound again.


Well-known Member
Common problem with Arcam I'm afraid.
I remember trying to update the firmware 6 months ago and went through 3 different USB sticks, it still wouldn't recognise the USB stick.

After many emails to Arcam technical support, they suggested that I use an very low capacity USB stick as the Arcam doesn't like anything over a certain memory size.
They sent me out an "Arcam" branded USB stick with the firmware on and it worked straight away.
It's only a tiny USB stick as far as on board memory is concerned.
It's one of the many many Arcam quirks I'm afraid. :(
Top Bottom