• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

Question Arcam AVR350 won't recognise CD or AUX inputs. Assist plse.

keeto

Standard Member
hello,
I have an AVR350[Arcam].
using CD and AUX inputs, neither one is recognised as a DIGITAL input.

I have tried a few others[analogue]. these are not picked up either.

i have used the reset feature[reset 1 & 2]. also the 'Stereo Direct' button.
I realise :( this doesn't look good...
but, i had a problem similar to one experienced by other folk with the same AVR350 issue onsite and ending with a success, in that, a solution[somewhat of a long term-3 days waiting] presented itself and did actually work.
an arcam supplier[ and technician] here in dublin, had a hard time with the proposed resolve to the issue...it worked however.

any and all off the wall[''] proposals or possible resolves, i would be most delighted to hear of. indeed, any possible answers :)
thanks for looking in,
keeto.
 

keeto

Standard Member
the issue since posting was down to the source/s.
the motherboard[in pc] turned out to be the issue, not the amplifier... :)
i also found out as a resutl of haste[ :( ] that an incorrect RCA cable was re-connected.
simple things can cause so much trouble especially when complicated by faulty 'grey matter'... :(
tth.
keeto
 

The latest video from AVForums

CES 2023 Round Up: New TV Lineups for 2023 from LG, Samsung, Panasonic, Hisense & TCL
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom