Arcam avr 450 problem with hdmi

dejanfrom67

Novice Member
Hello.
Going nuts with this Arcam 450, PC and 4k TV.

So...

If I connect hdmi from PC to TV, and I connect audio out from PC to RCA on Arcam, I get 3840x2160 resolution on TV and stereo sound from Arcam.
But if I connect PC to any in HDMI on Arcam and either of two out Arcam hdmi to TV, before it gets to the login screen, screen flashes few times ( a bitdifferent than fi PC is connected directly to TV via hdmi. Still lets me log in. But resolution is 1920x1080.
The moment I start browser, or even opening settings to manage resolution, withing a second or two screen starts flashing black, and then tursn to green at whin point I can only turn all things off.
If I do not proceed with the login I can do whatever I need using Arcam remote, as Menu is visible, with login screen from PC in the background.

I have tried numerous combinations in Arcam menu and on TV, with or without CEC, ARC, forcing 1.4 HDMI, connecting Arcam to ARC and non-ARC hdmi in on tv......
No combination worked.

Updated Arcam to the latest firmware.

What am I missing here.
Yamaha (RX-V1900) I had before worked flawlessly.

Please help.
 

dejanfrom67

Novice Member
What I was missing were the properly working drivers fo the PC. Pc is Lenovo M700 tiny Lenovo drivers were creating the issue in communication with 450. With the video and audio over HDMI drivers from Intel, as GPU is integrated into CPU, all is good.
 

The latest video from AVForums

AVForums Movies Podcast: We review Dune and ask which is the best decade for horror movies?
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom