Arcam AVR-100 Owners Please Read

Discussion in 'AV Receivers & Amplifiers' started by Dorian, Aug 9, 2001.

Tags:
  1. Dorian

    Dorian
    Active Member

    Joined:
    May 2, 2001
    Messages:
    532
    Products Owned:
    0
    Products Wanted:
    1
    Trophy Points:
    31
    Location:
    Lancashire
    Ratings:
    +43
    Sorry to repost a question but I want to get to the bottom of this :

    I have an AVR-100 with a hum in the centre channel speaker (which I must admit is very quiet) and clicking noises through the rear L/R channels caused by changing volume using the remote.

    Is this normal for an AVR-100 or should I return it for repair/replacement ?

    <br />Thanks,

    Domino
     
  2. AVMAN

    AVMAN
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Send it back mate,just to be on the safe side.I dont own one but i sell them and demonstrate them and ours dont do it.
     
  3. gatesy

    gatesy
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    I too had a 'quiet' hum from the centre speaker. Arcam fitted a ferrite ring to it which sorted this out. I didn't have the clicking you mentioned though. Arcam support are top blokes and will help you out if contacted.

    Cheers,
     

Share This Page

Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice