1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Arcam Amp Questions & Advice

Discussion in 'Arcam Owners' Forum' started by KWB, Dec 23, 2003.

Tags:
  1. KWB

    KWB
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Not sure if this is the right forum but would appreciate any advice…

    I have just upgraded my home cinema system to incorporate a Rotel processor and separate amps.

    I have the chance of purchasing an Arcam delta 290 integrated amp from a friend and have borrowed the unit for a demo. Before considering the Arcam amplifier I was going to purchase a Rotel 1075 5-channel amp however I would expect the Arcam to better the performance of the Rotel even though it is 10 years old (any advice on this?)

    I am using the amp as a power amp for my front speakers by feeding the processor into the direct line inputs on the back and selecting direct mode using the two push switches located on the centre of the front panel.

    The sound quality is good however I get a slight hissing noise from the speakers (KEF Q3’s) even if I totally disconnect all other inputs to the amp. The noise is not very loud and therefore you do not hear it when using the system, only if the amp is turned on and the background noise is low.

    I would like to know if this is normal? I have tried switching the source control switches and it does not make any difference. The amp is located behind the TV and I was hoping to leave it on when not in use, as I cannot reach the power button easily.

    My next question is providing the Arcam is ok I may consider buying additional Arcam amps for my centre and rear channels. My budget is limited and I was considering a further two Delta 290 amplifiers. I only require three channels of amplification and would like to know if I could obtain a three channel Arcam amp second-hand for a similar price to two delta 290’s.

    This is my first experience with Arcam products and I do not know what is available within my price range £300 - £400~ for 3 channels (second-hand).

    Can anybody offer any advice?

    Thanks
     
  2. dood

    dood
    Active Member

    Joined:
    Aug 4, 2000
    Messages:
    943
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    28
    Location:
    Hobart
    Ratings:
    +38
    I use a 290 to drive my fronts as a power amp. My denon 3300 acts as a processor, my speakers are kef Qs. I haven't noticed any hiss and the system works well, especially with the fixed gain when the arcam is used in processor mode.

    Could the hiss be coming from your processor? try disconnecting it from the arcam and connect a cd player directly into the arcam and see what happens.
     
  3. KWB

    KWB
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    dood - I am using the Arcam in the same way, set to processor mode and both switches on the front selected. I have bi-wired my speakers and connected my Rotel to the processor input on the back of the Arcon.

    The noise is more of a humming sound and I get this even if I disconnect all inputs to the Arcam as soon as the amp is switched on.

    I thought it may be interference from the mains supply and have tried removing the earth wire from the plug to check for ground loops etc.

    I would not say that the noise is very loud, however if the room is quiet and the Arcam is switched on I can definitely hear it from 2 meters away if I listen carefully.

    Can you hear any noise from your speakers if you listen carefully with just the amp switched on and no input signal?
     

Share This Page

Loading...