arcam alpha2 amp speaker posts

cooder1955

Standard Member
hi all,i have arcam alpha 2 amp from charity shop £10 powers up etc but it has no speaker posts tried google/ebay and arcam but no respnse yet but dont know what to ask/look for (size etc),dont know if it runs till i have speakers on,do i have a bargain and what do i ask for as regards the posts,many thanks for your help.
 

steeled

Active Member
I had an original alpha plus amp - many years ago. if I remember correctly the speaker sockets were standard 4mm banana sockets. These were flush mounted with the back panel. I think you are expecting the more usual combined 4mm banana socket/binding post. Where you can use either banana plugs, bare wire or spade connectors.

You will have to go to Maplins or your local friendly Hi-Fi shop and buy some 4mm banana plugs.

If I have got this wrong - then a picture of the back of the amp would help us identify what you have got.

Hope this helps.

Regards

Dave
 

cooder1955

Standard Member
hi,thanks for reply i have tried to upload pics but keeps failing.on closer inspection i thought fitting was screwin but i think the posts have been broken/pulled off and i think is beyond fixing,thanks again
 

ANDY_DUTTON

Active Member
So long as the amp still work you could mount some 4mm binding posts somewhere else on teh amplifers back pannel and wire from the PCB over to them. You will need basic soldering skill for this but not much else.

Andrew
 

The latest video from AVForums

Star Wars Andor, Woman King, more Star Trek 4K, Rings of Power & the latest TV, movies & 4K releases
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom