1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Arcam A85 Phono Stage Problem

Discussion in 'Arcam Owners' Forum' started by ozturk, Oct 4, 2004.

Tags:
  1. ozturk

    ozturk
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    I have an A85 with the optional MM/MC phono stage fitted.

    I have recently started using an MC stage but there is too much hum even at middle volume levels. My turntable is Project RPM9 with Ortofon Kontrapunkt A and interconnects are VDH MC 501 silver pair. I have tried with different interconnects but no change. The hum noise is still there even without any connection. When I switch it to MM section there is no hum at all.

    Has anyone had any similar problems? Is this the characteristic of Arcam phono stage or I have a faulty one?

    Many thanks in advance for any help.
     
  2. ANDY_DUTTON

    ANDY_DUTTON
    Active Member

    Joined:
    Aug 27, 2002
    Messages:
    498
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    28
    Location:
    Cambridge
    Ratings:
    +87
    The MC setting on the A85 is extreemly sensitive (as it has to be for MC) and will pick up hum from nearby transformers. Make sure your A85 is not sitting on top or underneath of another product with a transformer near the phono stage. Also ensure you have connected the earth lead from your turntable to the earth stud on the back of the A85.

    Regards,
    Andrew
     

Share This Page

Loading...