Apple TV 4k and flickering screen...

Mikef

Standard Member
HI, this is in relation to a first generation Apple TV 4K device, not the second version....

I have mine hooked up to a Sony KD 55X8509 set. When viewing material on Disney + and Netflix, I have started to see a 'flickering' effect in parts of the screen in dim/dark scenes. I noticed this first in the background when Loki started recently. I've not seen it before.

After changing various setting on the TV and the Apple TV box, I can only get rid of the flickering by turning off the Match Content options (Dynamic Range and Frame Rate) on the AppleTV, and having the Format set to 4K SDR.

Has anyone else seen this? Turning off the Match Content feels like it's a bad thing, I haven't really watched anything else since making the change so can't say what other impacts it may have...

Maybe I should just buy a more up to date television? :)

Any thoughts?

cheers

mike
 

Mikef

Standard Member
I'm not sure if this change means I get a little judder when the camera pans quickly...I might be just looking too hard. Not sure if having the format as 4K SDR makes a difference, will have to spend some time swapping back and forth and watching the same pieces of film

cheers
 

next010

Distinguished Member
I'm not sure if this change means I get a little judder when the camera pans quickly...I might be just looking too hard. Not sure if having the format as 4K SDR makes a difference, will have to spend some time swapping back and forth and watching the same pieces of film

cheers

From what I can make out the X5809C is a very early 4K set and seems to be 4K SDR from specs page, some TV vendors soft updated these early 4K TV's to support HDR but it was faked. So it might be that which is why it works fine with 4K 60hz SDR output.

The dynamic range setting in ATV controls switching between SDR/HDR based on source material so you can leave that off as you want SDR output at all times.

The frame rate setting will switch the output to match the video, so this means 24Hz output for movies, enable this option and that should give less judder on playback.
 

BillyBleach

Active Member
I have a lgcx and apple tv4k box(the one before the latest release). I get the flickering effect in dark/dim scenes in 2 series, fear the Walking Dead on prime and Liseys Story on apple plus. Everything else is fine. I googled it and it's not just us. But there's no definitive answer on how to solve it. As I've only seen it happen in 2 series it's nothing major, just a bit annoying.
 

Mikef

Standard Member
Cheers...as you say...I have only seen it on two programmes, and only in the last few weeks...might be time to buy a more up to date tv tbh....
 

Mikef

Standard Member
Just as I am thinking of buying a new Sony A80J, I see a review which mentions flickering in the shadows... :)
 

EL Dukeo

Well-known Member
I have a Sony A9g and this problem drove me up the wall for a few weeks till I found the cure which is turn off frame rate and match content. It was only on specific scenes this would happen on also. I thought the last apple update had fixed this but this week it showed up on something again.
You're not just stuck in sdr though, I found if you want to watch something hdr and set the apple box to output in hdr as long as you have the match dymanic range still off you shouldnt get the flicker. Same for outputting in dolby vison. Any absolute pain to have to do this manually though!
 

Mallett94

Distinguished Member
Leaving match dynamic range on is fine as this is the setting which will automatically change between SDR, HDR10 & Dolby Vision for you (which is a good thing).

If you want to disable match frame rate to avoid the flashing content which can very rarely rear its head, that is up to you, just make sure that when watching 24p content at 60hz you engage the appropriate motion setting on your tv to perform reverse 3:2 pulldown. If watching 25/50p content then manually change the refresh rate to 50hz.
 

Hurdledude

Novice Member
Here because I had the same issue watching the new season on demand on YouTube TV last night. Nvidia Shield Pro and Sony x930e. Dark scene background flickering so bad. I think it's just the show
 
I've been looking for solutions for weeks but unfortunately there aren't any.
It doesn't depend on your TV but on AppleTV and "Match frame rate".
If this (very useful) setting is activated, in black background scenes you will always notice a flicker which I personally find very annoying.
This only happens for SDR content (all of them, for me) while it never happens with HDR / DV content.

My tv is a 2020 Sony A8.

The alternatives I use are:

- local SDR content: disable "match frame rate" from ATV settings and use MrMC, which has the same setting enabled by default

- SDR content from streaming applications: I can use the tv's internal app or play with the motion options to get the reverse pulldown or change the refresh rate to the ATV.

This is all inconvenient and I hope apple gets his hands on it.

HERE you will find a discussion about it, with some sample videos.
 

Ace Of Wands

Well-known Member
HI, this is in relation to a first generation Apple TV 4K device, not the second version....

I have mine hooked up to a Sony KD 55X8509 set. When viewing material on Disney + and Netflix, I have started to see a 'flickering' effect in parts of the screen in dim/dark scenes. I noticed this first in the background when Loki started recently. I've not seen it before.

After changing various setting on the TV and the Apple TV box, I can only get rid of the flickering by turning off the Match Content options (Dynamic Range and Frame Rate) on the AppleTV, and having the Format set to 4K SDR.

Has anyone else seen this? Turning off the Match Content feels like it's a bad thing, I haven't really watched anything else since making the change so can't say what other impacts it may have...

Maybe I should just buy a more up to date television? :)

Any thoughts?

cheers

mike
I have a Phillips tv that can’t really handle HDR. You’ll hear many people say put Match Dynamic Range ON, but on a crap TV, HDR looks crap! You want match dynamic range OFF. Otherwise it will be too dark. It can’t handle the highlights / contrast and that’s why you get parts of the screen flicker. Like in a dark scene with a fire, or moon in the sky. I mostly watch things in SDR! SDR looks much more vibrant and colourful on my TV. God I’m really looking forward to getting a decent OLED in the near future.
 

Paul Shields

Well-known Member
I've seen it with an LG CX and 2021 ATV 4K. I think it's a problem with certain encodes (though it persists in pause sometimes) so probably a combo of tolerances between the source and the player software.

I bet the reason it goes away when match rate is off is that you're now converting 24hz source to 60hz and this process is probably eliminating the issue.
 

astirling

Well-known Member
Nah I think it’s more likely that the bug affects certain hdmi frequencies rather than the process of converting causing issues
 
I have done a lot of tests.

I also did this:
started a movie with no dynamic range match (because it was HDR) and flicker is present.

Started the same movie with dynamic range matching (to start HDR) and the flicker is not there.

Same movie, same refresh rate. The difference is only in the dynamic range.

Interesting to see that if on my tv (sony a8) I set the picture mode "Graphics" (or Game), the flicker disappears completely.

So it makes me think that some TV settings for cinematic image processing conflict with the ATV's frame rate match. (settings that the user cannot change, because I tried to set my picture mode the same way the Graphics mode is set, but it was not enough to remove the flicker)
 

The latest video from AVForums

Podcast: Sky Glass, Epson Laser Projectors plus Home Cinema Subwoofers and More…
Subscribe to our YouTube channel

Full fat HDMI teeshirts

Support AVForums with Patreon

Top Bottom