Apple TV 2G not waking up iMac.

SixNineFourSixSeven

Well-known Member
I seem to be having trouble. My iMac is set to go sleep after so long. Ice heard that when I turn my ATV 2G on or wake that from sleep state its supposed to wake up the mac to allow the ATV 2G to access iTunes.
This is not happening and I have to then go up stairs to move the mouse and physically wake the iMac.
While not a huge problem is it's not working as it's supposed to.
ATV 2G is connected wired to a Time Capsule and iMac is connected wireless on the Time Casual over it's 5ghz network.
I've checked and it is capable of waking on demand but it never works.
 

quinx

Standard Member
I take it you have 'wake for network access' checked in energy saver system preferences?
 

SixNineFourSixSeven

Well-known Member
yes i have.
If i move the mouse the mac wake ups and ATV can see my computer. once the mac has gone sleep (hard drives and all) it never wakes up and my ATV just keeps trying to find my computer.

If my mac is alseep and i try to connect but dont go up stairs to wake the mac myself but instead turn off the ATV then turn it back on and go to my computer the ATV tells me to turn on home sharing on itunes (which is turned on) but don't come up with my computer name.
 

quinx

Standard Member
Well I agree that from everything I've read it should work. (I don't have a time capsule myself - but was looking into getting one partly to do exactly this.) What you're getting is basically the same as I get without having the bonjour sleep proxy on my router at all.

The only other thing I can think of is whether the firmware on your time capsule is up to date?
 

SixNineFourSixSeven

Well-known Member
just found this
There's a further limitation with Wi-Fi: if you've enabled WPA or WPA2 encryption on the base station to which your Mac is associated, that base station must act as the main base station on the network; it can't be configured as a bridge, Apple says. If you're not sure whether your base station is bridging network traffic, go to Applications -> Utilities -> AirPort Utility, connect to your base station, click on Manual Setup, and choose the Internet icon. If Connection Sharing is set to Off (Bridge Mode), then wake over wireless won't work. (The most likely reason you'd have your base station acting only as a bridge is if your broadband modem is already providing network addresses via DHCP.)
i have checked my settings and mine is in bridge mode !
i'm not clued up enough now to change it.
 
Last edited:

SixNineFourSixSeven

Well-known Member
right i think i now have sorted it. got it sharing a public ip in the settings everything is still connecting to the internet but i will see if its waking up the imac later
 

quinx

Standard Member
How did you get on?

Wake on wireless is a feature of your time capsule router, but currently it sounds like you're not actually using the time capsule as your router - it's just passing through and broadcasting what it gets from your modem - so you're not using any of its router features!

I think - tentatively - that it should be as simple as opening airport utility, clicking continue to change settings, and going through until you have the option to "create a wireless network" instead of whichever you currently have.

Your new network will have a different name etc from the one you're currently connected to, so you'll have to reconnect all your wireless devices to the new network - but it should then work as advertised.

Quinx
 

SixNineFourSixSeven

Well-known Member
How did you get on?

Wake on wireless is a feature of your time capsule router, but currently it sounds like you're not actually using the time capsule as your router - it's just passing through and broadcasting what it gets from your modem - so you're not using any of its router features!

I think - tentatively - that it should be as simple as opening airport utility, clicking continue to change settings, and going through until you have the option to "create a wireless network" instead of whichever you currently have.

Your new network will have a different name etc from the one you're currently connected to, so you'll have to reconnect all your wireless devices to the new network - but it should then work as advertised.

Quinx
if i tried to change the Connection Sharing from off (bridge mode) to share a single IP address i'd get a conflict error saying there was a problem between my DCHP & WAN being the same.
I had to factory reset and changed a few things (i really can't remember what it was but it had something to do with DCHP and not using it which resulted in the share a single IP address being selected.
I can connect to the internet with both my iMac & Macbook Pro and the ATV 2G at the moment seems to be working with wake on demand.
I'll continue to do further testing but all seems in order.
 

SixNineFourSixSeven

Well-known Member
well after a few weeks of testing im going to go with...........its not working.
At the moment my mac is asleep (using option-cmd-eject shortcut).
My Apple TV & macbook cannot connect to the iMac.
Home-sharing on both are not available.
I've selected Create a wireless network
I'm no longer using bridge mode and every device has its own DHCP address which is automatically given.
I'm using either WPA or WPA2 as requested.
I'm now giving up.
 

The latest video from AVForums

Star Wars Andor, Woman King, more Star Trek 4K, Rings of Power & the latest TV, movies & 4K releases
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom