• Welcome to AVForums running Xenforo 2.2. The upgrade from 2.1 was successful and finished in just 90 minutes. We're still rebuilding the database indexes, so searches won't be reliable for a few hours, but we feel it's more important to bring the forums back online. The most notable changes in 2.2 are listed in this post. Thank you for your patience.

App store seems buggy on iPad

Mentally Hill

Standard Member
Is it just me or are others finding the app store a bit buggy, slow & generally pretty un-slick?

Filtering doesn't appear to work
'Show more' on chart view works only sometimes
Performance is v slow overall
Can't check 'top free' or 'top paid' in category view

Few other minor niggles but generally is a pain and quite frustrating to use.
 

bdrob

Member
I agree, I think it's partly why I have so few on here thus far.

Another gripe is that after clicking show more a few times, checking out an app and them going back toreset list sometimes results in it resetting to the original ten. Bleh.
 

Mentally Hill

Standard Member
I agree, I think it's partly why I have so few on here thus far.

Another gripe is that after clicking show more a few times, checking out an app and them going back toreset list sometimes results in it resetting to the original ten. Bleh.

Yep I get that one too.

Hopefully this is all temporary as it ain't a place to browse n buy just yet.
 

rbj

Active Member
Yeah I have found it very buggy, I often cannot find apps on there that I have searched for that I know exist.
 

The latest video from AVForums

Podcast: Q Acoustics Q3030i, Humax Aura, Roku Streambar & WandaVision Reviews and more...
Top Bottom