1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Anyone use a Denon 2800 MkII?

Discussion in 'Blu-ray & DVD Players & Recorders' started by hi_robb, Nov 20, 2003.

  1. hi_robb

    hi_robb
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Lo there folks,

    First of all I've searched through the forums and got some answers, but these are the ones that haven't really been answered so far.

    I've got chance to buy a Denon DV2800 MkII on the cheap (about 240 quid). While the price is fairly good, and I'm in the market for a new dvd player, I'm a bit concerned by things I've read on this forum, so I would like to ask a couple of questions.

    1: Does anyone own one of these players? Can they comment on it please.

    2: I know there are various firmware updates which allow the use of multi region or pal progressive.

    Is anyone actually using both features with no problems? I'm particularly interested in lip snyc problems when using progressive scan.

    Tia

    Dave
     
  2. Dimmy

    Dimmy
    Banned

    Joined:
    Jan 15, 2003
    Messages:
    2,399
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    39
    Location:
    England
    Ratings:
    +0
    I have an un-updated DVD2800mkII and can say - especially at £240 - it's one of the best players available IMHO.

    There are unnofficial firmware updates available for the enabling of Multiregioning on the player. There is now an official PAL Progressive firmware available.

    There are users using both features with no reported problems, but there are probably more with problems. Who have subsequently changed the player for something else or just been left with a non-working player.

    Whether you can get a working DVD2800MKII that has been multiregioned and is PAL Progressive enabled depends entirely on the firmware modification used to update the player with. Some work, some have too many side effects.

    The firmware releases that work have probably been mentioned in past threads which you should search for.
     

Share This Page

Loading...