Anyone had enough of their Thomson since getting the new EPG?

Chadford

Distinguished Member
I have. :mad:
After fixing the PSU and fitting a 1TB drive my Thomson box has been rock solid - no problems for a long, long while now.

Since the new EPG...
1) Occasional failed recordings.
2) Occasional cancelled recordings ??????what????
4) Occasional failed 'technical fault xx' recordings.
5) Occasional crashes whilst watching a program (requires power cycle).
6) Occasional fails to come out of standby the following day (requires power cycle).
7) Always painfully sluggish.
8) The misses now wont use it, she doesn't have the patience to wait whilst the thing buggers about after a key press.

NOT GOOD ENOUGH.

...and reading other posts I'm certainly not the only one with these problems.

It's time for it to go, and thats in the bin I wouldn't want to sell it on eBay and give someone else the problem.

I'm not going to leave Sky. I will grudgingly pay £49 for a *NEW* Samsung or Pace - but that's it. I'm confident Sky will not agree to giving me a new box as they will tell me my box is faulty (nothing to do with the new EPG). I don't want a Thomson refurb, so since me and the misses are not married then I think I'll get her to take out a new account and I'll close mine. :mad:

Being a longterm loyal customer of Sky is of no benefit, shame really. :(
 

loz

Distinguished Member
Have 2 thomsons.
Never upgraded PSU, or disk....

Have the new EPG
Have none of those problems...
 

simon194

Well-known Member
Since my Thomson was updated 5 weeks ago I haven't had issues 1-6 that the OP lists.

As for point 7, Ok it's a a bit slower but not sluggish.
 

nobby1963

Active Member
Hi,

Well my Thomson that had previously had no probs ( apart from a rare reboot ) has now started playing up as in the OP`s case. I am also getting major sound problems on all channels - the sound either goes very very quiet and `muffly` or goes off altogether.

I had enough at the beginning of this week, emailed Jeremy Darroch, got a call back 2 days later from a young lady in the `executive department`.

Long story short, I have had a call from Sky tech support, not able to fix over the phone, a Sky `engineer` is coming out Sunday with a new box.

All I can say is I have it in writing in an email that I will be getting a new box not a refurb. I have had to assert my rights to get this and was initially told before my email to Jeremy Darroch that I would have to pay £65 for a service visit and that there was no way I would get anything other than a refurb replacement.

I know that there will be others who say that I have got more than Sky have to do -i.e. they dont have to give me a new box for my 18 month old Thomson but I was not prepared to give up my `looked after` box for some second hand god knows what box that has had who knows what done to it.

Good Luck to others with problems .....
 

Chadford

Distinguished Member
Hi,

Well my Thomson that had previously had no probs ( apart from a rare reboot ) has now started playing up as in the OP`s case. I am also getting major sound problems on all channels - the sound either goes very very quiet and `muffly` or goes off altogether.

I had enough at the beginning of this week, emailed Jeremy Darroch, got a call back 2 days later from a young lady in the `executive department`.

Long story short, I have had a call from Sky tech support, not able to fix over the phone, a Sky `engineer` is coming out Sunday with a new box.

All I can say is I have it in writing in an email that I will be getting a new box not a refurb. I have had to assert my rights to get this and was initially told before my email to Jeremy Darroch that I would have to pay £65 for a service visit and that there was no way I would get anything other than a refurb replacement.

I know that there will be others who say that I have got more than Sky have to do -i.e. they dont have to give me a new box for my 18 month old Thomson but I was not prepared to give up my `looked after` box for some second hand god knows what box that has had who knows what done to it.

Good Luck to others with problems .....

Wow! can you post after Sunday and let us know how you got on?
 

SamRadford

Well-known Member
It's time for it to go, and thats in the bin I wouldn't want to sell it on eBay and give someone else the problem.
You should be able to get a good price for just the rebuilt PSU and HDD. :)
 

Hamie

Standard Member
I have. :mad:

Since the new EPG...
1) Occasional failed recordings.

Mine is daily...

2) Occasional cancelled recordings ??????what????

Yep

4) Occasional failed 'technical fault xx' recordings.

Yep.

5) Occasional crashes whilst watching a program (requires power cycle).

Yep... It just hangs... Usually more when using the EPG itself.

6) Occasional fails to come out of standby the following day (requires power cycle).

Not seen this one yet...

7) Always painfully sluggish.

Yep. I even turned off the mini-tv. No difference

8) The misses now wont use it, she doesn't have the patience to wait whilst the thing buggers about after a key press.

Yep. Mine disappears upstairs to watch the old Sky+ box we have.

NOT GOOD ENOUGH.


Not good enough by half... Hopefully youre replacement box will sort you out. But what sort of muppets do this lot take us for? Do they do NO usability testing? Their testers should be crucified. Publically. Along with the marketing muppet who decided that this was a good idea.

Being a longterm loyal customer of Sky is of no benefit, shame really. :(

Sky care nothing about customer service. They know they have a monopoly. And are intent on abusing it as long as they can.
 

EAC1885

Standard Member
My Thomson HD box was functionally fine after the upgrade - no crashes, failed recordings etc. The EPG itself was a little slower though, and the fan(s) seemed to like to stay on for longer.

I did have a problem with my multiroom Sky+ box though. That began to suffer from picture and sound dropout, which having had a look around various forums seemed to point to a dodgy PSU in my Thomson HD box. Not really a big surprise as its still the original.

I've since swapped to a Pace box (with upgraded 1TB HDD), and with the new EPG it's excellent. Makes practically no noise, faster EPG, and the channel blanking issue has gone :clap:
 

HDCriticalFan

Active Member
Even after my PSU upgrade I used to get the "won't come on in the mornings" problem about once a fortnight.

Since the new EPG (about five weeks ago) this hasn't happened once.

I have had no failed recordings either (but I never used to get them anyway).

I've even turned Anytime back on now !


I have a 1Tb disk which is about 40% full with over 100 recordings (and perhaps a dozen stacks). I don't find the EPG to be particularly sluggish - but the "Planner lag" (which seems to vary perceptibly as my number of recordings and stacks varies) is about 3-4 seconds. It's really annoying :mad:

In the last week or so I have noticed two things :

When FFwding, the box sometimes refuses to accept the "play" command ... no matter how many times you press it (the remote blinks - so I know that isn't the problem). It will accept "pause" though - after which it will accept play. Very strange.

From time to time I've started to see a slight delay when in the EPG. I can press "down" two or three times, thinking that the coffee table has got in the way ... and then a couple of seconds later the cursor goes down three lines.


But overall the new EPG has given my ageing Thomson a new lease of life.





Regards
 

cooleo

Active Member
I have. :mad:
After fixing the PSU and fitting a 1TB drive my Thomson box has been rock solid - no problems for a long, long while now.

Since the new EPG...
1) Occasional failed recordings.
2) Occasional cancelled recordings ??????what????
4) Occasional failed 'technical fault xx' recordings.
5) Occasional crashes whilst watching a program (requires power cycle).
6) Occasional fails to come out of standby the following day (requires power cycle).
7) Always painfully sluggish.
8) The misses now wont use it, she doesn't have the patience to wait whilst the thing buggers about after a key press.

NOT GOOD ENOUGH.

...and reading other posts I'm certainly not the only one with these problems.

It's time for it to go, and thats in the bin I wouldn't want to sell it on eBay and give someone else the problem.

I'm not going to leave Sky. I will grudgingly pay £49 for a *NEW* Samsung or Pace - but that's it. I'm confident Sky will not agree to giving me a new box as they will tell me my box is faulty (nothing to do with the new EPG). I don't want a Thomson refurb, so since me and the misses are not married then I think I'll get her to take out a new account and I'll close mine. :mad:

Being a longterm loyal customer of Sky is of no benefit, shame really. :(

I am having the same probs but I have been quoted £199 for a "NEW" box. Only your first hd box is £49. I was on the phone to them in total for 1h 55m!! Got passed around various depts. and eventually was told if I was not happy I could write to head office or CANCEL!!!

Fantastic customer service I must say!
 

avinitski

Member
yes my box after the new EPG is driving me mad.

only got it installed mid January. I have done no modifications to the box.

Often get 'no satellite signal is being received', never really used to get this. Full system reset is my only option which deletes all my recordings and Anytime.....annoying.

Last week for about 2 days i could get no Information on future programmes on any channel either through the planner or the onscreen info bar, i could only view Information for the current showing and none for future programmes even the next programme, they all said 'Programme synopsis not available. Rebooted the box and forcing software download did not happen. It just started to work again for no reason.

Another issue was i could not pause or rewind any channel, cant remember what the exact message was but something like 'There is a technical fault'. That too went away by itself.

Only had the new EPG 2 weeks if that. Not a good start.

edit: bugger ive just realised....think ive got a Pace! sorry!
 
Last edited:

Bachstrad

Well-known Member
I have a Thomson with no mods to hd or psu and still running just fine here both before and since the new EPG arrived. :thumbsup:

ATB

Max
 

Chadford

Distinguished Member
Since my Thomson was updated 5 weeks ago I haven't had issues 1-6 that the OP lists.

As for point 7, Ok it's a a bit slower but not sluggish.

Exactly my own experience! (with a Thomson 4E3007 and upgraded 1Tb HDD)

How full is your planner?

About 98% currently! I urgently need to clear some things out!

Hmm thought a full 1TB planner may cripple the Thompson's performance, obviously not.
 

Chadford

Distinguished Member
I've found out a couple of things today:

1) Sky are actively fixing the Thomson sloooooowness problems and a fix will appear soon :)rolleyes: whens that? 'don't know can't tell you').


2) If you previously had your Sky HD installed by an independent retailer, then you can apply to Sky for a new install, new box, 1 Year guarantee, etc..
£49 + (whatever it is for an install, about £30 I think).
 

Chadford

Distinguished Member
I've found out a couple of things today:

1) Sky are actively fixing the Thomson sloooooowness problems and a fix will appear soon :)rolleyes: whens that? 'don't know can't tell you').


2) If you previously had your Sky HD installed by an independent retailer, then you can apply to Sky for a new install, new box, 1 Year guarantee, etc..
£49 + (whatever it is for an install, about £30 I think).

2) ...and also choose the box you want, providing you are happy to (book another install and) turn away installers that doesn't have the box of your choice on their van.
 

chic

Distinguished Member
i have a tompson which has the new epg and i have a terabite drive fitted and also upgraded the power supply and i have only had 2 failed recordings which which happenbd when i was duel recording and the second recording didnt start. A power cycle fixed the problem and i have carried out many duel recordings since all with no problems.
 

mrm3

Active Member
I have had problems with my Thompson box for a while. I was going to upgrade the PSU after reading some good reports and as I was having problems with HDMI signal dropping out.

I swapped to using component cable and have no issues at all. My reboot every other day has stopped too and no failed recordings on the new EPG.


Be interested to see if anyone wants to give that a go.

Thompson Sky HD PQ on HDMI and Component seems to be about the same anyway.
 

BrianMc

Active Member
Hmm thought a full 1TB planner may cripple the Thompson's performance, obviously not.
I suspect that the new EPG folders are virtual and that is part of the cause of my Planner taking about 2-3 seconds to appear. As I have about 150-200 recording for it to look at I can forgive it that delay (but it would be nice if it became faster!)
 

Mackle

Active Member
Since the new EPG...
1) Occasional failed recordings.

I get this


2) Occasional cancelled recordings ??????what????

4) Occasional failed 'technical fault xx' recordings

Not had these


5) Occasional crashes whilst watching a program (requires power cycle).
I know my box did this BEFORE the new EPG, am really not sure if it's done it afterwards

6) Occasional fails to come out of standby the following day (requires power cycle).
I know my box did this BEFORE the new EPG, am really not sure if it's done it afterwards


7) Always painfully sluggish.
The performance of the EPG and the speed of navigating it on my Thompson box is shocking. Some times I have to power cycle the thing because it just gets confused buffering up key presses.


My Sky HD box had not been modified and is original in every way.
 

The latest video from AVForums

Podcast: LG C1 OLED + JBL Synthesis SDR-35 First Thoughts, plus TV Show & Disc Reviews & more
Subscribe to our YouTube channel

Latest News

Austrian Audio launches Hi-X65 headphones
  • By Andy Bassett
  • Published
Roku expands streaming content with Roku Originals
  • By Andy Bassett
  • Published
What's new on Netflix UK for June 2021
  • By Andy Bassett
  • Published
AVForums Podcast: 12th May 2021
  • By Phil Hinton
  • Published
Bluesound unveils new generation of Node and Powernode audio players
  • By Andy Bassett
  • Published

Full fat HDMI teeshirts

Support AVForums with Patreon

Top Bottom