1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Anybody have a Kef Egg sub fail

Discussion in 'Home Cinema Speakers' started by tobytronic, Dec 4, 2004.

  1. tobytronic

    tobytronic
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Mine has power but no output. I've triad many cables, sources so it is def. broke.

    Any experiance of similar from anyone ??
     
  2. Oi Oi Savaloy

    Oi Oi Savaloy
    Active Member

    Joined:
    Jul 26, 2004
    Messages:
    133
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    21
    Location:
    Chertsey, Surrey
    Ratings:
    +9
    I've blown a tweeter before on the centre egg.....but it still worked.....Alan
     
  3. wallisj

    wallisj
    Active Member

    Joined:
    Dec 14, 2004
    Messages:
    244
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    21
    Location:
    Nottingham
    Ratings:
    +11
    I did...had the speakers for about 4 months and the sub just died one day...powered on but no output...took it back to creative audio and they fixed in an hour by replacing the main board inside (seems to be common).
     
  4. Mr Cat

    Mr Cat
    Banned

    Joined:
    Jul 23, 2003
    Messages:
    2,190
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    51
    Location:
    Weardale
    Ratings:
    +57
    I've heard reports of the subs failing due to a faulty curcut board..???
    I'm sire someone can give more info on this tho...
     
  5. dochall

    dochall
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    It seems to be a fairly common problem with them.

    I sent mine back to Kef without the receipt and they could check it was covered under warranty with the serial number. (I have a fairly early one with a five year guarantee I think they have dropped that to a year now).

    They replaced the board and it took around a week to turnaround.
     
  6. LITTLEBRITAIN

    LITTLEBRITAIN
    Banned

    Joined:
    Nov 28, 2004
    Messages:
    289
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    19
    Location:
    Greater Manchester
    Ratings:
    +0
    hi all! yep this is quite a common fault either no power or power with no sound.
    usualy when theres no power something majour has blown on the main pcb (smoke & black caps etc)
    its a 5min job to replace amp module and kef are aware of the problem so usualy replace.
     
  7. Tejstar

    Tejstar
    Well-known Member

    Joined:
    Dec 4, 2002
    Messages:
    22,482
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    136
    Location:
    London
    Ratings:
    +990
    Is the Kef egg sub the PSW-2500 or is it a different model number?
     

Share This Page

Loading...