Anthem MRX 310 'popping'

pantages

Active Member
I recently purchased the Anthem 310 and performance wise it is excellent. However when I use the remote control to switch inputs I hear a feint 'popping' noise from my speakers. I have checked all the connections and they all seem fine. Any advice please?
 

Violator

Well-known Member
I recently purchased the Anthem 310 and performance wise it is excellent. However when I use the remote control to switch inputs I hear a feint 'popping' noise from my speakers. I have checked all the connections and they all seem fine. Any advice please?
Are you actually switching inputs or switching between SKY channels? The popping switching between 2.0 and 5.1 SKY sources is quite well known.
 

T7BSY

Banned
I have a Arcam that does the same thing, i also had the Anthem 300 which pops during all the advert as the go from one to the other, no fix for this im afraid, you just get use to it, or not :)
 

pantages

Active Member
Okay, thank you, I will live with it! It is barely noticeable and for the performance of the 310 is worth living with!
 

pantages

Active Member
The 310 started to switch itself on from standby, at anytime of day. It also froze after I switched it on and would not allow me to do anything until I had switched off the mains supply and then back on. That receiver was such a pain I was able to get it replaced by another 310. The new 310 worked fine as a switching unit between my Sky box and tv using HDMI and ARC. My tv is a Samsung H8500 and uses Anynet to communicate with the 310. Anynet worked fine, I would press tv 'on' on my Sky remote and the tv, Sky box and 310 would all switch on in sequence.

However I have my tuner and CD player connected via co-axial and after using my CD player I discovered that I was unable to get the 310 to work as it did previously. I spent 2 hours checking settings, (none of which changed on the 310 or the tv), disconnecting and reconnecting cables, switch off at the mains for the tv and 310 and back on, but the 310 refuses to recognise any of the inputs. I now have the Sky box connected direct to the tv via HDMI and audio to the 310 by optical. TV audio is also connected by optical as ARC refuses to work. My BD player is connected to the 310 by HDMI and works fine although the auto switching has become ineffective. Now I am using the 310 in its basic mode which defeats the object of buying it in the first place.

Over the years I have owned around 20 different amps/receivers and I never encountered such issue. I am truly disappointed by the 310 and it is only its sound quality that has made me persevere. I have told my dealer this and that I will keep the 310 but I still feel let down. Has anyone any comments or advice for me please?

I added this to my existing thread because I couldn't find the button to start a new thread!
 

The latest video from AVForums

Star Wars Andor, Woman King, more Star Trek 4K, Rings of Power & the latest TV, movies & 4K releases
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom