• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

Question Annoying, intermittant problem with NAS access.

Rog69

Distinguished Member
I have a NAS (WD Mycloud) directly connected to my router. My main PC is connected to the router via a 4 port switch in my study. Everything is hard wired.

Intermittently I am unable to access the NAS drive from my main PC (Running Windows 10), I cannot connect to it and access any content but I am able to ping it and access it's dashboard via my web browser. When this occurs the various other devices on my network, some hard wired and some wireless (laptops, games consoles, phones, tablets, smart TV etc) can all access the content on the NAS as normal.

The problem comes and goes without any pattern, I was unable to access the NAS from my PC for most of last week but this morning it is back to normal again. The problem is obviously with my Windows 10 PC but I am really scratching my head as to what might be going on here.

Any Ideas?
 

next010

Distinguished Member
Could be a bunch of things that are the cause but i's tricky to pin one down.

For example it could be interoperability issues (linux samba vs win smb) thats why you can ping it and other devices can still see it but one PC cannot. In some cases the solution to this is to set the linux samba server as the local master browser in it's settings if you can. However from my understanding WD rarely allow you to tinker with advanced settings and really this sort of issue shouldn't be popping up on a consumer device.

If you can't do the above what you could try to do would be to power off all devices with SMB/Samba support then power on the NAS first so it's the master in SMB election, then power on the troublesome PC next (so it sees NAS as master) and remaining devices after that.

Don't WD have a cloud desktop software that allows file management on the NAS, can it still see it and copy files back and forth ? might be a crude workaround.

Is firmware on the NAS up to date ?
 

Rog69

Distinguished Member
Thanks for that.

Yes, the firmware on the NAS is up to date, it was one of the things I tried last time the issue occurred and it wasn't, but updating it made no difference. I have tried various combinations of rebooting the NAS, Router and PC and I just couldn't resolve the issue.

It doesn't look as though I have the ability to change any settings beyond the basics in there. I am not running any of the WD software on anything at the moment but I guess it is worth a try if or when the issue pops up again.
 

The latest video from AVForums

Spielberg, Shyamalan, Aronofsky, Chazelle, Eddie Murphy and Mel Gibson - all the latest movies
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom