Annoying buzz

Discussion in 'Hi-Fi Stereo Systems & Separates' started by Frosticles, Dec 21, 2006.

Tags:
  1. Frosticles

    Frosticles
    Standard Member

    Joined:
    Jan 31, 2006
    Messages:
    24
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    1
    Location:
    Near Nottingham
    Ratings:
    +0
    Hi there, I am currently experiencing a really annoying buz from my Hi-Fi when I connect either my LCD TV or DVD Recorder to the pre amp. pre/power amps are Arcam alpha 9's btw. When my CD player is connected all is fine but as soon as either the tv or dvd is connected then this buzzing occurs which will not go away even with the sound switched off. Sounds to me like an earth fault but I have changed leads and have tried the components in all of the inputs to no avail. Anyone have any ideas p;lease? Many thanks, Kev.
     
  2. leon

    leon
    Active Member

    Joined:
    May 15, 2001
    Messages:
    1,160
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    51
    Location:
    kent
    Ratings:
    +67
  3. Frosticles

    Frosticles
    Standard Member

    Joined:
    Jan 31, 2006
    Messages:
    24
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    1
    Location:
    Near Nottingham
    Ratings:
    +0
    Hi there, have been advised by the people you mentioned in the link to get a Ground Loop Isolator. have bought one and will try and see if it cures the problem this evening. Thanks for your help, Kev.
     

Share This Page

Loading...