Anker Soundcore Life P2 out-of-sync when used with Bluetooth Adapter

My Anker Soundcore Life P2 earbuds have an audio/video sync problem when used with a Bluetooth adapter. It isn't an issue when connected to my computer since I can adjust the sync but when connected to my TV there is no way to adjust the sync. I have tried 3 cheap adapters and was wondering whether purchasing a more expensive adapter with low latency would fix the issue? Incidentally, this issue does not occur when using the same adapters with my other earphones, although they are not true wireless earphones like the P2 are. Can this issue be fixed? TIA
 

natty

Active Member
I see the life p2 supports aptx, but not aptx low latency. So a low latency transmitter may not cure your problem.
 
I see the life p2 supports aptx, but not aptx low latency. So a low latency transmitter may not cure your problem.
There's no lag when connecting to my phone, which obviously has Bluetooth built in. Could this mean that a better transmitter could solve the issue or is a built-in transmitter completely different to an adapter?
 

natty

Active Member
I think i heard somewhere that there is some processing going on in phones and tablets that mitigates any delay. But it doesn't seem to work with tv's. The only surefire way is that both the transmitter and headphones are both low latency.
 

The latest video from AVForums

Panasonic LZ2000, LZ1500 & LZ980 Hands-on Launch Event | No QD-OLED for 2022, new 77-inch for LZ2000
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom