Amp receiver problem. No sound from speaker

jggns

Novice Member
Hello I’ve recently discovered a new passion for home cinema/projector.
I’m the building the system up slowly and have very little knowledge other than I know I like this a lot. I would be grateful if anyone can help with the problem I have encountered.
Iget sound from an old pair of JVC speakers on any of the surround, center L & R, but my brand new acoustic 3020i speakers have no sound at all when connected into the back of the amp with larger connections for FRONT. I have cleqee banana plug screw type connector adapter going into the amp.
the Sony amp model is STR DH520 if that helps. I’ve tried various settings, but cant get any sound from them at all.
Any help or advice would be much appreciated

paul
 

Attachments

  • BB81C4F3-7660-4D2E-865D-0FD115E37B43.jpeg
    BB81C4F3-7660-4D2E-865D-0FD115E37B43.jpeg
    406.7 KB · Views: 26
  • 9562ACA9-32F3-47BD-96B5-9E4C38AD63EF.jpeg
    9562ACA9-32F3-47BD-96B5-9E4C38AD63EF.jpeg
    466.8 KB · Views: 30
  • 4FEBE487-BBF1-4BD3-9BF9-A5E32B7E7719.jpeg
    4FEBE487-BBF1-4BD3-9BF9-A5E32B7E7719.jpeg
    416.8 KB · Views: 30
  • 8F6BE2E1-233F-45F3-915E-833BCB487553.jpeg
    8F6BE2E1-233F-45F3-915E-833BCB487553.jpeg
    388 KB · Views: 31
  • E980191B-F542-4767-AB5C-D1D680506EF7.jpeg
    E980191B-F542-4767-AB5C-D1D680506EF7.jpeg
    318.2 KB · Views: 22
  • 90D1E321-5D36-4991-813D-DB51A01C97C6.jpeg
    90D1E321-5D36-4991-813D-DB51A01C97C6.jpeg
    256.1 KB · Views: 26

noiseboy72

Distinguished Member
You need to remove the black plastic plugs from the ends of the binding post speaker connections on the amplifier. The bannana plugs will then plug in same as your speakers.
 

DodgeTheViper

Moderator
Just out of curiosity. How did you have the speakers connected anyway ?
 

jggns

Novice Member
Hi Dodge I have only tried one Logitech speaker so far. Banana plugs into the speaker and then the thinner bent style banana plug into the amp
 

DodgeTheViper

Moderator
Ah right ok. I was just wondering when you said no sound was coming out of the 3020's yet it looked like they'd not been connected yet.
 

The latest video from AVForums

AVForums Movies Podcast: We review Dune and ask which is the best decade for horror movies?
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom