Amp gone bad, bit of advice needed.

Discussion in 'AV Receivers & Amplifiers' started by Alun, Apr 30, 2007.

  1. Alun

    Alun
    Well-known Member

    Joined:
    Sep 15, 2004
    Messages:
    2,604
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    106
    Location:
    Praying to the God of Wind
    Ratings:
    +243
    I have a Yamaha 2500 amp which recently went wrong. It would turn on, and then turn itself immediately off. According to :rtfm: its the speaker protection circuit operating, however, it still displays this fault with no inputs and no outputs connected up.

    I took the amp back 3 weeks ago, and rang the store up today, they say its been returned and is ready to pick up, but that the engineers could find no fault with it.

    Has anyone else had a similar scenario? Whats the best way of dealing with this???

    Cheers,

    Alun
     
  2. Chris Moseley

    Chris Moseley
    Active Member

    Joined:
    Apr 21, 2006
    Messages:
    160
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    66
    Ratings:
    +322
    Hi Alun

    The protect circuit does not only operate if there are speaker connection faults - it also protects agaist many other possible problems. When it does enter protect mode it writes a log which the service centre can read - so no guess work is needed to find out why it's protecting itself. It may take time to diagnose specifically what's causing the fault but they should at least be able to say why it was entering protect mode.

    If you not getting any where give me a call.

    Regards

    Chris Moseley
    Yamaha UK
     
  3. Alun

    Alun
    Well-known Member

    Joined:
    Sep 15, 2004
    Messages:
    2,604
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    106
    Location:
    Praying to the God of Wind
    Ratings:
    +243
    Thanks Chris, nice of you to take the time to reply. I have asked the store to connect and power up the amp, which they have agreed to do so, and I will be getting back in touch with them today to find out if they have seen the same symptoms that I had.

    Cheers,

    Alun
     
  4. Alun

    Alun
    Well-known Member

    Joined:
    Sep 15, 2004
    Messages:
    2,604
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    106
    Location:
    Praying to the God of Wind
    Ratings:
    +243
    I have the amp back and so far so good. Gave it a good workout over the last couple of days and all seems well. The store have agreed that should it develop a similar fault down the line that there will be no issue with it getting sent off, and a loan amp given:thumbsup:

    Global Hi-Fi customer service is excellent:smashin:
     

Share This Page

Loading...