• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

AM signal not working

Boro22

Active Member
Would anyone know why my AM signal in car is not working. FM works fine.

Is there a different connect that I am not aware of? ie aerial is fine, and solitary aerial conenction on back of head unit is fine.
 

Julie

Well-known Member
No, AM & FM use the same aerial in all car audio units. It's most likely to be a fault with your head unit I'm afraid.
 

Boro22

Active Member
It cant be, as it has happend with 2 differents HUs now....
 

Boro22

Active Member
can anyone help?
 

Boro22

Active Member
anyone?
 

zircon3035

Active Member
I fitted a new head unit last weekend and I also now have no AM reception. Mind you, FM is also a bit weaker than before. I'm beginning to wonder if the antenna is amplified and the new head not is not powering it. Another job for the weekend.
 

Boro22

Active Member
I have checked the attenae behind head unit already, and it seems fine. As I said, happpened on 2 different head units now so so strange!

Let me know how you get on.
 

Aerojon

Active Member
what car is it???????

alot of aftermarket headunits don't have power wire to supply the amplifier..
 

Boro22

Active Member
what car is it???????

alot of aftermarket headunits don't have power wire to supply the amplifier..


It is a Honda Civic. Supply what amp? my seperate amp?

in ref to your signatory. has SAAB gone under?
 

The latest video from AVForums

Fidelity in Motion's David Mackenzie talks about his work on disc encoding & the future of Blu-ray
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom