Alpine IXA W407BT Bluetooth issues with Iphone

Haubjes

Standard Member
Hello all, new guy from the Netherlands!

I recently acquired a car which has an Alpine IXA W407BT headunit. It works great, except for the following: I can pair it with my Iphone, and then all the bluetooth functions work. For example, my phonebook is transferred, missed and dialed calls etc. I can stream through bluetooth, I can make and receive calls.
However, it just won't connect again! If I switch off the car, and then switch it on again, it won't autoconnect. I can pair it again, but then I have to go through entering the 4 digit code again, which is a PAIN! After switching it off, it does not show up in the paired device history.
Is this a blueooth software issue? I just dont understand that the bluetooth itself works flawless, but the auto connect won't.

If I check the bluetooth firmware it says "0". If I check the alpine website for bluetooth updates, it says only 1.60, 2.00 and 2.51. Besides that, I currently own a Mac which is not supported. So if I have to update, which file do I choose, and will it cure the issue?

I just checked pairing it with a Blackberry curve. Pairing goes fine, can make calls etc, no problems of any kind. But, this phone also doesn't autopair! I don't know if the unit is supposed to do it, but it doesn't seem to be storing the devices. If I turn of the car, and then turn on again, neither the blackberry nor the iphone shows up in paired devices? I know it's not paired at that very moment, but it seems like some sort of memory to me?

Hope any of you knows a solution.
 

iamtheuser

Standard Member
There seems to be some kind of bug in BT module.
I have the same problem and i've seen others report it too.

For example no matter what I do I can't get the W407 to keep the new BT firmware after it's been updated if I remove the power from the unit.
Update process goes well and so do every step in the ignition toggle on/off as the update instructions state. I can verify that I'm on 2.5.1 revision.

But removing power and I'm back at firmware '0'.
I've emailed the Alpine support and they are looking into it but Ive havent heard anything more yet.

I did my updates from both my MacPro running Vista as well as a stationary PC with XP. Same problem.
 

Haubjes

Standard Member
A few days ago I had a friend come over and using his windows laptop we tried to update the headunit.
This went down pretty weird! At first, we couldnt make a connection between the laptop and the headunit. After a while, it did connect and started updating! Update went well, and got the message that it was succesful. The manual then stated that I had to turn off the power, for the new software to load when powered back on. Oddly, it still showed software version "0"!!!
We then tried version 1.60, Strangely enough, the computer told us that the software on the headunit was newer than the one we tried to put on, so the computer at that point noted that it had version 2.51 on it. We did manage to then get 1.60 on, but the same thing happened. After a power off and on again, it showed "0". We gave it a few more tries, but to no avail. We did once saw software version "00" and once we even saw software version "0ß" or something? The manual said that if it came up with version "000" it had to be powered off longer. We tried this, but that didnt make a difference. And it didnt show "000", just "0", "00" and "0ß" or something. Very odd.
Does anyone here have a clue?
 

The latest video from AVForums

Are the TCL MiniLED TVs better than OLED? TCL Interview with Marek Maciejewski | AVForums Podcast
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom