1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ALPHA 5 CDP distorting

Discussion in 'Arcam Owners' Forum' started by keith_nz, Jun 30, 2004.

  1. keith_nz

    keith_nz
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    i have an alpha 5 that is distorting really bad. if i remove the audio PCB and then put it back together it goes fine for a minute or two and then starts distorting and eventually the right channel stops. leaving a terrible sounding left channel.

    any ideas?

    i haven't been able to test the digital output.
     
  2. booktrunk

    booktrunk
    Banned

    Joined:
    Feb 6, 2004
    Messages:
    602
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Location:
    Leicestershire
    Ratings:
    +3
    It is old and tired :) maybe it's saying please replace me with a CD73

    (sorry, i'm going for the most unhelpful post of the day award).

    Steff
     
  3. John Dawson

    John Dawson
    Member

    Joined:
    Jan 16, 2001
    Messages:
    852
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    43
    Location:
    Cambridge, UK
    Ratings:
    +112
    Keith - sorry to hear about this but the good news is that we've come across this before and know how it can be repaired relatively easily.

    It's a bit complex to post the details of the fix on here - so I will be sending you a PM with the e-mail address of the person in Arcam who knows exactly what you need to do.

    Of course we 'd be delighted if you were to buy a new Arcam player as well :)

    John Dawson (Arcam)
     

Share This Page

Loading...