• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

Album details not changing in EAC or iTunes

Jimbo1982

Novice Member
Hi all,

I Recently got around to ripping my CD collection into lossless, for storage purposes on my NAS.

To do this i started using EAC and it was working a treat until yesterday, play back was working nicely with iTunes etc.

I popped in The White Stripes De Stijl and ripped it no problem. I stuck the next C D in and it still reads the details from The White Stripes album.

I figured it was just having a moment so i shut it down and tried ripping it through iTunes, same thing happens it shows the details of the White Stripes album. So i went a step further and rebooted to see if that would clear things. Still no success it still shows the White Stripes. I ripped the cd anyway and the audio came out correctly but with the White Stripes track markings.

Now every CD i put into either drive shows the White Stripes tack details, but they play fine. I can't figure out what I've done and was wondering if you could help.

Thanks
 

Basinguy

Established Member
Interesting, im using EAC for the same reason as you and haven't had that problem yet.

Try going to the top menu 'database' and then 'clear current cd information' then re-fetch cd info and see what happens
 

The latest video from AVForums

SVS Prime Wireless Pro Powered Speakers - Review Coming Soon
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom