1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Age of Empires 2 - wont play??

Discussion in 'PC Gaming & Rigs' started by Timbersnake1, Jan 23, 2005.

  1. Timbersnake1

    Timbersnake1
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    I have just installed Age of Empires 2 on my computer. Its the first game I have ever installed on this machine. Its not the most powerfull machine but should be able to cope with this game!! Its AMD 1200 mhz, 20GB HD and 256 Ram.

    When I first loaded the CD-Rom (Age of Kings) it came up with the options window and i chose full installation. This appears to have happened fine. The game installed and is located in c:/program files/microsoft games/Age of Empires II. It also Put a shortcut on the desktop.

    I restarted the computer as you should do, then loaded the disc back into the drive and double clicked on the AOE2 desktop icon. The loading window briefly pops up and then suddenly i get an error message 'Cannot locate the CD-ROM. Please insert the correct CD-ROM, press ok and restart the application'.

    I have done as it requests, but it doesnt work, just the same error message. I have checked the box and instructions, no other discs i need to using inside.

    Why does my machne happily read and install the game from the disc, but refuses to recognise and play the game from the same disc afterwards?

    HEEEEELLLLPPP!!!! :lease:
     
  2. Obuggrit

    Obuggrit
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    If i t's an external drive it could be due to that, other than thatI don't know.
    You try finding a no-CD crack, or making an image of the disk with a virtual CD mounting program. I've never used one, but I hear one called Daemon should do it well.
     
  3. Obuggrit

    Obuggrit
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Ah. Try this: Go to Device Manager and look at the properties on your CDROM drive - if "disconnect" is ticked untick it. I might help. Tick DMA on it too, most CDROM drives work with DMA
     

Share This Page

Loading...