AE500 issue.

Discussion in 'Projectors, Screens & Video Processors' started by GoggleBoy, Oct 3, 2004.

  1. GoggleBoy

    GoggleBoy
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Hi All,


    I have a AE500 and its my first PJ.( Love it to bits )
    I have had it for around 5 months and I just started to notice that when the pj is showing a black screen. There are 2 small round slightly lighter patchs that are visable. When theres colour on those points you can't see a thing.
    I guess it could be dust but I wanted some advice before I started taking my pj apart or contacting Panasonic.

    Cheers,
    GB.
     
  2. Fjorko

    Fjorko
    Active Member

    Joined:
    Apr 25, 2003
    Messages:
    511
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    31
    Location:
    Port Elizabeth
    Ratings:
    +24
    Yep , sounds like dust to me.....

    I have had it twice so far, and removed it quite easily !
    Can of air is what you need....
     
  3. GoggleBoy

    GoggleBoy
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Thanks for the feedback.

    I will have a look around for a guide on how to clean the PJ.


    Cheers,
    GB
     

Share This Page

Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice