Advice for Opera Consonance Wax Engine lp's skipping

Stefee

Standard Member
Good day people,

Long time lurked and collector of good advice on this forum.

I have an Opera Consonance Wax Engine turntable fitted with an Opera Consonance T88 duo pivot 9 inch carbon fibre arm carrying a fairly new AT VM95ML cartridge. The deck is perfectly levelled on an SRM Tech twin layer silent base with sorbothane isolating discs between the layers and spikes into cups on an Alphason AV cupboard.
Thumping the cupboard does not provoke any jumping of the stylus or noise through the speakers.
All records are cleaned via Project vacuum cleaner system, an anti static gun is used, the record cleaned with a carbon fibre brush, the stylus brush cleaned and a "dust bug" used and I still get instances of the record sticking and repeating at a random area or fuuzziness in the the treble prior to a skip and having to clean some stray hair off the stylus.
The overhang, cartridge alignment, tracking weight, anti skate, arm height and rotation speed are all absolutely spot on. I do not use any mat but do use an Inspire record pick however this makes no difference.
Has anyone got any ideas or comments to stop this happening because it sounds extremely good when playing before the inevitable jump or dirt pick up?
For reference the turntable goes to a Rega Elicit R via a Graham Slee Reflex MM phono amp into MA Silver 300 6G speakers.
I have had several suspended and solid decks in the past which never had these problems but they did not sound as good as this one when playing correctly.
Any help would be greatly appreciated however if I cannot cure these concerns another deck will be on the cards and a reluctant sale made.

Thanks in advance.
 

Ugg10

Distinguished Member
The ML does like to be at the 2.0g end of the recommended weight and the anti-skate at the same setting (or middle of three notches if on a physical weight and string system). Which alignment did you use?
 

Stefee

Standard Member
Thanks Ugg10 for your reply.
I initially set the tracking at 2.0 grammes and had the anti skate on the middle notch and no luck. Increased to 2.2 grammes, same results. Then increased arm height at rear slightly but no improvement.
I don't know if it is anything to do with the duo pivot bearing design as I have never had a system like that before, just so frustrating.
 

Stefee

Standard Member
I set up the cartridge with a custom made alignment protractor from The Vinyl Source based on the Lofgren A pattern specifically made for the tonearm if that is any help.
 

The latest video from AVForums

AVForums Movies Podcast: We review Dune and ask which is the best decade for horror movies?
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom