Acto AT-X5250 Power Issues

Mattrne

Standard Member
Hi all,

I've just moved from Canada to Scotland and have brought with me my Acto AT-X5250 projector. I am aware that the voltage in the UK is 240v and that in Canada is something like 110v. With that in mind I have been wanting to check if my projector will work here.

Now having inspected the unit, it says that the input is '100-240v - : 3.0-1.5A:50-60Hz'. With that in mind I thought there would be a switch on it somewhere to swap it from 110 to 240 but I cannot find a switch anywhere and I can't find my user manual.

Does anyone know if its just a simple case of me plugging in a UK power plug or if there is actually a switch I need to flick first?

Any help would be massively appreciated because I havn't had much luck via google so far...
 

marley

Active Member
Hi all,

I've just moved from Canada to Scotland and have brought with me my Acto AT-X5250 projector. I am aware that the voltage in the UK is 240v and that in Canada is something like 110v. With that in mind I have been wanting to check if my projector will work here.

Now having inspected the unit, it says that the input is '100-240v - : 3.0-1.5A:50-60Hz'. With that in mind I thought there would be a switch on it somewhere to swap it from 110 to 240 but I cannot find a switch anywhere and I can't find my user manual.

Does anyone know if its just a simple case of me plugging in a UK power plug or if there is actually a switch I need to flick first?

Any help would be massively appreciated because I havn't had much luck via google so far...
I am 99.99% sure the unit is power-auto detect but wait for someone else to double confirm it. Voltage: 100V - 240V
 

The latest video from AVForums

Star Wars Andor, Woman King, more Star Trek 4K, Rings of Power & the latest TV, movies & 4K releases
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom