Acer Revo R3610 2gb + Windows 7 = running slow.

Ohjin

Novice Member
Hi all, hope someone can help.

I have a Acer Revo R3610 with 2GB RAM.
I did a fresh install of windows 7 yesterday (plus all the updates), everything seemed to go fine.

Loading apps is fairly quick etc, but every so often the computer just bottoms out. When I open up for instance, chrome, it will take 5 mins to load up. once it loads, the computer works fine again, everything is quick, all other apps load quick, but then say 10 minutes later, the bottom will just drop out again, and apps will go to 5 mins again to load up.

Does anyone have an idea as to what to do or try in the problem solving.

I have seen these machines being sold with windows 7 already installed on them, so I know it can handle windows 7.

Thanks for you're time

Owen
 

Uridium

Distinguished Member
Swap the HDD for an SSD....
The slow 5400rpm 2.5" was the biggest problem with the Revo R3610. Swapping it for even an older SSD will transform it.

If your not used to stripping hardware it may be a little intimidating as you will need to split the case and remove the motherboard (HDD is stupidly retained by screws on underside of motherboard) but realistically it's a 15 minute job and there are some good guides on Youtube for it.
 

The latest video from AVForums

Star Wars Andor, Woman King, more Star Trek 4K, Rings of Power & the latest TV, movies & 4K releases
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom