1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

A85 Volume Control problem

Discussion in 'Arcam Owners' Forum' started by Baltika_no_9, Jun 27, 2005.

  1. Baltika_no_9

    Baltika_no_9
    Standard Member

    Joined:
    Apr 5, 2004
    Messages:
    62
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    8
    Ratings:
    +1
    I needed to have the firmware upgraded on my A85 so that I could have the Processor Mode option available to use it in a home cinema set up. The amp went back to Arcam and came back with the new firmware version 3.4, the old one was 1.3. Whilst it was with Arcam they also apparently upgraded the amp to the "latest mod spec" whatever that means and the dealer charged me £159 for this. I have to say I wasn't expecting to have such work done nor indeed to pay for it but what the heck.

    Problem now is that the volume control is defective, adjusting the volume up or down causes either huge noise spikes, unbearably loud sounds or zero sound. I can turn the volume up but the sound can go up, down or disappear from one or both channels, same when I try to turn the volume down, what actually happens is completely arbitrary. Same with volume knob or remote control, same when speakers are disabled with the A/B switches when listening through the headphone socket. Same problem when the amp is warm or cold. Adjusting the volume is completely erratic. Tried different sources, still the same. Disconnected everything, connected a single source and speakers, still the same.

    The box is going back to the dealer this week but has anyone else had this?
    any idea what I paid £159 for in terms of upgrading my 2000 vintage amp to the "latest mod spec"?

    Is it time to buy my long lusted after A32 or will that go the same way?

    Cheers
     

Share This Page

Loading...