A lot of issues trying to fly my drone.


Standard Member
Mar 13, 2022
Reaction score
New Zealand
Hi there, i'm pretty new to all this, i've only got 4hrs fly time so far. and for the first few weeks had no issues, worked really well, could fly well and seemed easy. However recently i've had issues where it's stopped going forward or backwards, or left or right, this has happened several times after flying just fine for 5 mins or so, and when it's got stuck going forward and i can't control it, the ONLY thing i can do when that happens if the left and right work is to fly round in fast circles trying to keep it from hitting buildings, then lowers it's altitude, and perform a controlled crash into a hedge ideally. it's quite scary when it gets stuck going forward as i don't know where it's going to end up. also on a few occasions the left and right stopped as well as forward backwards so when i fly it gets stuck, all i can do is try bring it down in a straight line, and i've hit a few buildings doing so. thankfully not damaging the Mini SE. i'm worried as if this was to happen when i'm far from home or when i'm over water then that's it, i can lose my drone forever, and at some point it's going to break the drone if i keep crashing into objects.

The other worrying thing, is when it's stuck flying forward the Return home switch doesn't work either, as the RTH effectively performs an up and forward left right motions, so these motions don't work, and the drone won't stop and return to home, there's not much i can do other than try crash it.

sometimes when i turn it on as well it won't stop beeping and i think that's related, i googled it a bit and people say sometimes the RC sticks gets stuck, mine aren't stuck, but they suggested power off the control, rotate the sticks in circles a few times and try again. i've done this, this does seem to stop the beeping issue, and it seems to help sometimes with the control, but also i seem to have to do this every time i use it. others say i need to re-calibrate the RC sticks. so i followed the instructions to do this and i noticed the issue, not all of the sticks commands were working, in fact in this example video i show, i can't even get the altitude to work, just rotate L and R, and the right stick for the movement doesn't work at all.

After i took this video i turned it off and re-loaded the RC Calibrate and it was doing different stuff, left stick worked perfectly, right stick worked only on left, then when i let go, it seemed to be stuck on left even although the stick was fine and central. Finally i re-booted the controller again, and went to the RC Calibrate and it worked 100% that time and i completed the calibration. but if i go back into it, the next time it won't work fully again.

I'd love to know if anyone else here's experienced similar issues or know of a fix, firmware seems up to date, do you think there is a problem with the actual controller here, it's never been dropped and is only a few weeks from new and i have looked after it very well.

Here's a video of me trying to calibrate the RC...

Last edited:
If your trying to calibrate the controller then it seems a strange way to do it. I own a mini1 and have had no problems with it, but like most of my other drone controllers I do have to calibrate them every now and again. I'm really not sure what process your doing using your fingers on the control sticks one at a time. I've always held the controller in the flying position and moved the sticks in all directions [both ] at the same time [using my thumbs].
There definetly seems a problems with yours. You are waiting for satellites to be picked up before taking off? You have the latest firmware installed?There is not a problem with the phone?Have you tried uninstalling the app and then reinstalling?
the way i showed this here was simply to make it clear to the PC camera, but even if i use both sticks at once it does the same thing, it doesn't work a lot of the time on the right stick controls. i do have satellite control yes, i wait until that is all ready and the latest firmware is installed. i haven't however deleted the apps, so i may try that next. i'm pretty confident it's not the drones fault, but the controller, the same thing happens when i use the Litchi app so it seems to point to the controller being the issue.
I have a feeling this is all related. The problems on the other thread seem to be similar to what I saw yesterday. I will contact DJI

The latest video from AVForums

Sony BRAVIA 9 Mini LED TV: The Best HDR TV EVER?
Subscribe to our YouTube channel
Top Bottom