Quantcast

A bit late but an explanation would be nice . . .

M

minimad

Guest
A couple of weeks ago my dad bought Tivo. Yesterday he took it back as he was having somany problems:

1: It took five hours to download what it needed for updates.
2: Without hitting the bypass button, he could get video but no sound.
3: When he set the machine to record it would, but then the play back would be jittery, as if the HDD was trying to "housekeep".

Has anyone else had these problems, are they uncommon, or was my dad just bl**dy unlucky? It's put him off buying another for the moment, I would like to get him another one but would like people's opinions first.

Thanks

Collin
 

gringottsdirect

Active Member
After downloading the latest software, which it is normal to take hours because a lot of Tivos are very old stock being cleared, they are mostly trouble free.
No offence to your dad but it could be a bit too fiddly for him.

Skyplus+ is a lot simpler for him.
 
M

minimad

Guest
lol

He's only 57 and he works with telecommunications systems! I don't think it was too fiddly, but never having played with it I couldn't say.

The thing that concerned me was the "jittery" playback. ho hum. I'll get him to try another unit (if I can convince him).

He has said that he feels Sky+ is too expensive. :(
 

gringottsdirect

Active Member
Originally posted by minimad
The thing that concerned me was the "jittery" playback. ho hum. I'll get him to try another unit (if I can convince him).

Definitely not " jittery " when Tivo working normally.

( Still think it's fiddly though :D )
 
M

minimad

Guest
:D

Perhaps I'll get him to get another and I'll set it up for him - my mind hasn't quite gone yet!

Many thanks for your help. :)
 
Top Bottom