55pus8204 ruined since update!

Matt henshaw

Novice Member
Hi, I cant be the only one with this problem so I've joined this forum in the hope there are more people with the same issue.. ive had my tv since early 2020 and it has been fantastic! I initially had a problem with a video and audio delay but that was fixed with an update shortly after my purchase. But.. in January this year philips released a new update which has bought this incredibly frustrating issue back! The video is ahead of the audio so cannot be fixed by any settings on the TV or connected devices.. it is so bad its almost unwatchable! And I've just noticed the alexa side of the TV has gone now too as I used to be able to control the TV with alexa and now I can't! There's not even a section in the menus to connect to alexa anymore.. philips customer services are absolutely useless, and far short of telling me to reset the TV have said nothing more! Does anyone else have this issue?? I don't know what to do next as this has ruined an otherwise brilliant TV! Many thanks..
 

JayCee

Distinguished Member
Have you tried power-cycling it since the update?
If you have your only option is to try a reset.
 

Matt henshaw

Novice Member
I have, and done a full reset as per the advice from philips.. but the problem remains.. nothing in my set up has changed.. just the update.. its clear that the update is flawed, as a few people have had issues with alexa too..
 

Matt henshaw

Novice Member
Quick update, have managed to reset alexa and it's now working fine.. still have the video and audio delay though....😔
 

The latest video from AVForums

Samsung S95B QD OLED Review - A Quantum Leap for OLED!
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom