43” X85J HDR wonky on PC

DeadStaar

Novice Member
Hey guys, so I’m using the X85J, 43” TV, on my PC and it looks sickly. I don’t have the text/ font issue everyone else seemed to have. That looks fine. I am running the display at [email protected] 120Hz.

In short:

YCbCr 4:4:4 and TV set to Auto is washed out to the point of looking like a 16bit Windows 95 desktop. Setting HDMI rangr to Limited is only subtly better.

RGB 4:4:4 (Full) is much better, but the saturation (?) issue continues, but setting the HDMI range to Limited pretty much perfects it.

Turning HDR off, only on the TV results in an extremely washed image (not pictured), it looks a bit like the first images, but worse. Setting HDR to Off on both PC and display produce an image pretty similar to RGB 4:4:4 (full) and HDMI range set to auto. Which is a very subtle washed effect. So it appears even turning HDR off is not the solution.

Moving over to Halo: Infinite, using the best settings I found for the previous game, Elite: Dangerous, it seems to hold but I wonder now if this is considered crushing blacks(?). But setting to Auto isn’t bad either. Any ideas of what I may be missing?

Now, I just noticed, while turning HDR off on PC and the TV made Halo look more washed out than ever…except when I Alt+Tab to switch the app, you can see the thumbnail of the game running looked perfect. Now Halo doesn’t have a committed Full Screen option, only a borderless windowed mode, a thing many have been complaining about, mostly because of the better performance gained by running in dedicated full screen mode. Elite, on the other hand runs Full Screen.
 

Attachments

  • EF04F76C-441D-4F26-921A-FE1C2487DFCB.jpeg
    EF04F76C-441D-4F26-921A-FE1C2487DFCB.jpeg
    282.9 KB · Views: 29
  • 36075D69-CC13-4990-B4D9-E206BD3DAF46.jpeg
    36075D69-CC13-4990-B4D9-E206BD3DAF46.jpeg
    666.3 KB · Views: 28
  • CB6CB59B-10AF-42F3-A2C1-DAD125D60337.jpeg
    CB6CB59B-10AF-42F3-A2C1-DAD125D60337.jpeg
    268.3 KB · Views: 29
  • 57E56CAB-4217-4160-A9C8-D43143529DC9.jpeg
    57E56CAB-4217-4160-A9C8-D43143529DC9.jpeg
    246.6 KB · Views: 29
  • B82F8B7D-B241-4EE7-A6D3-CCD9C8061260.jpeg
    B82F8B7D-B241-4EE7-A6D3-CCD9C8061260.jpeg
    265.7 KB · Views: 25
  • 288B6DD5-CD90-4E48-9B09-9E06DDD581B4.jpeg
    288B6DD5-CD90-4E48-9B09-9E06DDD581B4.jpeg
    260.7 KB · Views: 31
  • EF94AAFE-4885-48C8-BC89-55B4A2EFC69A.jpeg
    EF94AAFE-4885-48C8-BC89-55B4A2EFC69A.jpeg
    278 KB · Views: 29
  • 6BC79648-8E56-4EC4-83C3-C87E8A02A5CD.jpeg
    6BC79648-8E56-4EC4-83C3-C87E8A02A5CD.jpeg
    308.1 KB · Views: 28
  • 8A2802E4-EE95-4589-B682-32EDEA877411.jpeg
    8A2802E4-EE95-4589-B682-32EDEA877411.jpeg
    316.8 KB · Views: 32

DeadStaar

Novice Member
I just realized that the pictures did not upload in the order I needed them in, while doing it in batch. And no way to edit/ delete your post, apparently.

The more washed out pics are of YCbCr 4:4:4, either set to full (worse) or limited (slightly better), while the two of the more subtle effect are HDR off and RGB 4:4:4 (full) and the TV set to auto (with HDR off) and HDMI limited (with HDR on). They produce a similar result.
 

DeadStaar

Novice Member
Okay it appears I resolved this. Originally I had opted Enhanced Signal Format, for both HDMI 2.1 ports, for the PS5 and PC, which are HDMI 3&4, respectively. But I did not know there was an option, if you tab to the right, on each port, to choose a Wizard that will enhance them for the respective device types. When I chose “Enhance for PC” it set the PC to YCbCr 444, 60Hz, and HDR to off. I then re-enabled HDR and could set the HDMI range back to auto and it looked fantastic! So, the moral here is the PS5 requires no optimized setup and looks brilliant. PC needs a little help however.
 

The latest video from AVForums

Samsung QN95B 4K QLED TV Review
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom