3G iPhone on T-Mobile network help please

pacificdragon

Active Member
Hi there, I purchased the iphone from CPW and purchased a turbo sim from an online retailer ( not ebay ) and I can make / receive telephone calls and text messages but cannot access the internet unless connected via wifi..

I've checked the web and used all the APN's out there,, I was wandering if anyone had any ideas if there is something else I should be doing below is the APN details I've used all with no luck.

Many thanks :lease: :lease: :lease:

apn general.t-mobile.uk
username user
password wap

apn general.t-mobile.uk
username user
password pass

apn general.t-mobile.uk
username wapuser
password wap

apn general.t-mobile.uk
username user
password one2one
 

ROBIN50N

Well-known Member
might sound daft but is your 3g turned on in settings? and also is your sim a 3g one?
 

J7MAN

Member
Matt C is your man, he'll be along soon.
 

ROBIN50N

Well-known Member
hes got the 2g though, think 3g settings are diffrent.
 

J7MAN

Member
His internet isn't working at all though.
 

pacificdragon

Active Member
might sound daft but is your 3g turned on in settings? and also is your sim a 3g one?

I double checked just to make but the label that says Enable 3G is on and my sim is defo 3G sim card as I had the Nokia 95 and the HTC Touch with TM and was able to do internet push email etc so I assume it's a 3G sim card.

I've also got 3G written beside the T-Mobile on the front screen which should mean I'm receiving a 3G signal???

I've sent an email back to the shop I bought the power sim from just to see if they have any solutions but still no internet :thumbsdow
 

ROBIN50N

Well-known Member
are you turning wifi off when trying? other than that am not sure.
 

pacificdragon

Active Member
I don't know what happened but for some unknown reason it's working I guess it's like my wifi router works 364 days a year but there's that one day for some unknown reason it has it's day of fun and doesn't work and cheeses you off anyways,

The APN setting is the first one I posted that works

APN = general.t-mobile.uk
USER = user
Passowrd = wap

I know it's only been 10-15 mins but everything works excellent on here, it somehow knows my voicemail box number, so it was as easy ( almost ) as putting the turbo sim in with my sim card ( no cutting techy stuff etc ) and hey presto the phone works.

I had the phone since the weekend and used the o2 payg sim, so jailbroke my phone as soon as I got in and customized downloaded useful apps etc and I gotta say LOVING THE IPHONE I just wish Apple who sell this sim unlocked or at least to all the networks who want it,,, it's a great piece of kit,,,

If anyone does have any questions that are not to technical please give me a shout and will answer as I haven't found to many people yet with 3g iphones on T-Mobile yet.......:thumbsup: :thumbsup: :thumbsup:
 

steeleez

Active Member
I could be wrong, but I think you have to purchase a web'n'walk bundle to get mobile internet on t-mobile, I've had to, now mine works fine.
 

Matt_C

Distinguished Member
Matt C is your man, he'll be along soon.

hes got the 2g though, think 3g settings are diffrent.

Yeah mines the 2G model, tho the settings should be the same so long as both handsets are on the same firmware.

what was strange when I unlocked my iPhone was it accessed the web straight away before I even put any APN details in it! Off it went onto the web over the cell net (GPRS only cos mines 2G). Likewise my voicemail just worked off the bat, no entering anything there, aswell as text messaging (no message centre number tomfoolery :D ) so I pressume all this data is stored in the sim somehow?

Anyway, back to the 3G bit - I have read a bit on the net saying that a lot of people have found that with sim-adapters, like the Turbosim and Rebelsim, have had probs accessing web data over 3G/GPRS - drop outs, cut off's, and plain ol "just not working" and some have rectified it temporarily by sticking the sim in a T-Mobile phone, then swapping it back into the iPhone. Just something to bear in mind should you not be able to access the web over the cell net again.

That said, I sometimes get drop outs on my 2G handset (which is unlocked so no sim-adapter), which is usually cured by simply dialling my voicemail. For example, it won't download any emails and says "error couldn't connect to imap" or something like that, and Safari might through up that it coudln't conect to the server, so a 1 sec call to voicemail usually solves it. I did used to get a few errors like this when this sim was in my Nokia N73 : sometimes would get "Web'N'Walk Connection Error" or something like that so I don't really think anything of it.....
 

ROBIN50N

Well-known Member
Yeah mines the 2G model, tho the settings should be the same so long as both handsets are on the same firmware.

what was strange when I unlocked my iPhone was it accessed the web straight away before I even put any APN details in it! Off it went onto the web over the cell net (GPRS only cos mines 2G). Likewise my voicemail just worked off the bat, no entering anything there, aswell as text messaging (no message centre number tomfoolery :D ) so I pressume all this data is stored in the sim somehow?

Anyway, back to the 3G bit - I have read a bit on the net saying that a lot of people have found that with sim-adapters, like the Turbosim and Rebelsim, have had probs accessing web data over 3G/GPRS - drop outs, cut off's, and plain ol "just not working" and some have rectified it temporarily by sticking the sim in a T-Mobile phone, then swapping it back into the iPhone. Just something to bear in mind should you not be able to access the web over the cell net again.

That said, I sometimes get drop outs on my 2G handset (which is unlocked so no sim-adapter), which is usually cured by simply dialling my voicemail. For example, it won't download any emails and says "error couldn't connect to imap" or something like that, and Safari might through up that it coudln't conect to the server, so a 1 sec call to voicemail usually solves it. I did used to get a few errors like this when this sim was in my Nokia N73 : sometimes would get "Web'N'Walk Connection Error" or something like that so I don't really think anything of it.....
my 3g used to do that all the time and that was on o2 with full 3g signal. safari sometimes did nothing and i had to re boot. the main reason i took it back and canceled really.
 

JonStatt

Well-known Member
The swapping around of sims between phones was a hassle with earlier sim-hack cards like Rebelsim and turbosim etc.

However, I have had a v2 any-network hack sim with T-mobile in my iphone for over a week now and it hasn't lost signal once. In fact, it works just perfectly.

I notice that some of the other hack sim providers now have V2 ones as well...so perhaps this next generation of them are working properly now. The newer ones also don't require you to cut a corner off your SIM card to make room for the chip.
 

garyread

Standard Member
Hi
This is my first post and hope you can help. I have an iPhone 3G and just bought a TurboSim. My carrier is T-Mobile (UK) on 3G. (Essentially I have the same setup). However, I can't get things to work no matter what I try. I have tried the Turbosim instructions but still no joy. Could I have corrupted the TurboSim settings in some way or is the circuitry hard-coded? Otherwise, any ideas please?

Many thanks, in anticipation.

Gary
 

pacificdragon

Active Member
The turbo sim if it is the same as mine should just be a case of insert it with the sim card and your off,

One thing I would say is make sure the " turbo sim " fits flush onto the sim card,, I occasionally noticed at the start that the turbo sim was not always touching the sim card and caused the " no network " message on my phone.

I would obviously try not to touch the turbo sim anymore than you have to, can I assume your iphone still works with o2 sim card orginally provided ?

If the answer is yes then the good news is your iphone is fine might just need to fiddle about with the turbo sim or possibly buy a new one turbo ( I had to buy a second one for the reason above ) but all works fine...

The only other advice I would give would be if you are thinking of jailbreaking the phone etc I would do this BEFORE you do insert the turbo sim makes life a bit easier so you know stage by stage what is working and what may have caused any problems....

Apologies if the above is not helpful but took me ages to figure out the turbo sim was not flush against the sim card and that was the problem,, I restored my iphone xxxx times..... Good luck Brian.
 

garyread

Standard Member
I really appreciate that - thanks! I have got things working but Google maps can't find my location and I have a 'No Internet Connection' warning from Safari. It may be because I'm in a rural area and the signal may be a little dodgy but then again my N95 locks on immediately.

I'm off to the big city tonight and will test it then. Just to clarify, can you tell me your UPN settings?
I'm on the T-Mobile Flext 35 plan with the 'Web 'n Walk' add-on. (Not sure if that info is useful to you!). I have been thrilled with that plan and on the iPhone would be awesome.

Many thanks!
 

pacificdragon

Active Member
I really appreciate that - thanks! I have got things working but Google maps can't find my location and I have a 'No Internet Connection' warning from Safari. It may be because I'm in a rural area and the signal may be a little dodgy but then again my N95 locks on immediately.

I'm off to the big city tonight and will test it then. Just to clarify, can you tell me your UPN settings?
I'm on the T-Mobile Flext 35 plan with the 'Web 'n Walk' add-on. (Not sure if that info is useful to you!). I have been thrilled with that plan and on the iPhone would be awesome.

Many thanks!

This is the APN that I've put in my phone and works with my web n walk contract no probs,

apn general.t-mobile.uk
username user
password wap

As for safari it will only work when the APN details are entered correctly,, you can still make receive calls and texts without entering your APN but once entered you should be able to surf ( depending on your T-Mobile coverage ) also Google maps for me does not work indoors, I work on 28th floor of a central london building and have never been able to " lock onto my position " but the moment I step outside it works, likewise for my home address never get a lock when in doors but as soon as I step outside it's fine,,

Like you I had the N95 and never suffered the above problems but still wouldn't go back loving the iPhone :thumbsup: :thumbsup:
 

aldoscitech

Standard Member
hey i need help plz. a friend is selling my an iphone 3g but att is expensive and i've been looking for forums like this one. i'm from texas. i want to activate it with t-mobile. and get a 3g plan. will it be the same as with a att service? and which would be the best way to unblock it? plz help!!
thanks
 

hutch

Distinguished Member
The iPhone 3G isnt compatible with with the T Mobile USA 3G network at all, they use a frequency which isnt supported by the iPhone im afraid.

I believe the 2G iPhone works on T Mobile USA but as this is a UK forum with 99% UK members then I couldnt confirm that.
 

steeleez

Active Member
Has anyone found a solution to the problem of loosing 3G yet? I keep having to turn 3G off and on, reboot phone etc etc and I'm still having problems.
 

zoidy

Active Member
Has anyone found a solution to the problem of loosing 3G yet? I keep having to turn 3G off and on, reboot phone etc etc and I'm still having problems.

I havn't really had a problem with the 3G turning off and on a lot on T-Mobile, when it does go off it reverts to GPRS - normally when I'm on the train. I do get a total loss of mobile connection sometimes which is odd as the signal is good in my area, and I either leave it or reset it. I have a problem coming out of airplane mode though where the phone will not connect to T-Mobile - so now I pop out the sim when connecting to iTunes and I always get a connection after I reset the phone.
 

pacificdragon

Active Member
Has anyone found a solution to the problem of loosing 3G yet? I keep having to turn 3G off and on, reboot phone etc etc and I'm still having problems.

Did you suffer the same problem with your old phone on T-Mobile,, I have noticed that in some places the 3g drops off sometimes on the train going to the office in the morning but when I've put my o2 sim card in it does the same thing so I can only imagine it would be the network coverage rather than a fault with the phone or the sim card or the sim card adaptor
 

BiggieBig

Active Member
my 3G has totally dropped of on t-mobile over the past 3-4 days.

Any one expriencing the same problem.
 

hot-fuzz

Member
my 3G has totally dropped of on t-mobile over the past 3-4 days.

Any one expriencing the same problem.


YES.

I phoned up T-Mobile and they say that they had problems in the Essex/N.London area yesterday, but apart from that it should be fine. Im in the Surrey/Hampshire area and havent had 3G for a couple of days.

I was on here to ask if anyone else cant get 3G as mine dropped out sometime yesterday and cant get it back.

It works with my O2 sim, but not on T-Mobile.
Thank god there is someone else with that.
 

BiggieBig

Active Member
Thanks Space K

same syptoms but different problem.

anyway placed my sim in another phone and as reported ealier on this thread, all worked fine when I placed it back in my phone.
 
Hi guy's

I'm buying an iphone 3G soon (UK) and wanted to confirm that these are the settings used to access 3G and not the GPRS/Edge platform?

Thanks
 

The latest video from AVForums

Podcast: Philips TV Launch Event, Soundbar vs AVR, Samsung EzCAL and more...

Latest News

Philips debuts fifth generation P5 Picture Processing Suite
  • By Andy Bassett
  • Published
AVForums Podcast: 27th January 2021
  • By Phil Hinton
  • Published
Philips introduces new 9206 and 8506 LED Android TVs for 2021
  • By Andy Bassett
  • Published
Philips unveils 9636 and 9506 MiniLED TVs
  • By Andy Bassett
  • Published
Philips announces 806, 856 and 706 OLED TVs for 2021
  • By Andy Bassett
  • Published
Top Bottom