1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

2900 Sacd Playback Problem!?

Discussion in 'Blu-ray & DVD Players & Recorders' started by eatstatic, Aug 31, 2004.

  1. eatstatic

    eatstatic
    Active Member

    Joined:
    Oct 22, 2002
    Messages:
    1,126
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    51
    Location:
    Centre of the Universe
    Ratings:
    +44
    Anyone who has a Denon 2900 with the latest firmware having any problems playing SACD discs?

    Not noticed until now as my player has been packed away for some time while I have been working on the house. Can't remember testing player for SACD playback after flashing latest firmware so I am not sure if the thing has developed some sort of Denon hibernation bug or the firmware itself could be the problem :mad: .

    Only have the one SACD (Pink Floyd - Dark Side Of The Moon) which makes it hard to test also. Was going to buy another to see if I had same results but thought I would post first.

    Has anyone else had any problems like this since flashing the player with last firmware?

    Any help appreciated.

    eatstatic :lease:
     
  2. eatstatic

    eatstatic
    Active Member

    Joined:
    Oct 22, 2002
    Messages:
    1,126
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    51
    Location:
    Centre of the Universe
    Ratings:
    +44
    Where is everyone with multiregion 2900's with the last firmware upgrades?

    Suerly I am not on my own. :(

    eatstatic
     
  3. Radiohead

    Radiohead
    Well-known Member

    Joined:
    Dec 24, 2001
    Messages:
    4,295
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    106
    Location:
    Amazingstoke
    Ratings:
    +433
    I've a multi-region 2900 but have no idea what the firmware is. Personally I would always take mine to a dealer to be done anyway, as I'm generally suspicious about firmware floating about on the web. As my player doesn't appear to have any faults or bugs I see no obvious reason to play with different firmware.

    I've about 15 SACDs (inc DSOTM) and they all play perfectly...
     
  4. kumamoto

    kumamoto
    Banned

    Joined:
    Sep 2, 2003
    Messages:
    1,100
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    38
    Location:
    Watford
    Ratings:
    +17
    same here, my players is multi regioned and have never had any problems playing back SACD or DVD A software.
     
  5. Barend

    Barend
    Active Member

    Joined:
    Apr 12, 2004
    Messages:
    804
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Ratings:
    +9

    Maybe it would be helpful if you went beyond yourself and told us what the problem seems to be? :D
    Barend
     
  6. normsplace

    normsplace
    Standard Member

    Joined:
    Feb 1, 2004
    Messages:
    15
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I also own a denon 2900, which I flashed myself with the italian firmware making it multi region :thumbsup: I have only this week been playing both SACD and DVD AUDIO disc with no problems at all. The only problem I find is that I'm driving a set of KEF 5005 so there is a dramatic loss of bass whilste playing back both formats, this is easily sorted by cranking up the sub :)

    What is your exact problem??????
     
  7. eatstatic

    eatstatic
    Active Member

    Joined:
    Oct 22, 2002
    Messages:
    1,126
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    51
    Location:
    Centre of the Universe
    Ratings:
    +44
    Yup, the player does not recognise the SACD and shows 'NO PLAY', the machine can be forced to regognise the disc as a CD by holding down search, but that's yer lot, no SACD recognition.
    Everything else I have thrown at it it plays, DVD-A, VCD, KODAK, DVD, CD, CD-R all play fine.
    Prior to the firmware upgrade D.S.O.T.M played perfectly, it has no scratches and is in the as new condition so the firmware is the only thing that I can think of.

    eatstatic.
     
  8. steve1056

    steve1056
    Active Member

    Joined:
    Apr 20, 2002
    Messages:
    374
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Location:
    Reading
    Ratings:
    +5
    Have you set it up to recognize the SACD layer? You can find this option in the Set Up menu.
     
  9. eatstatic

    eatstatic
    Active Member

    Joined:
    Oct 22, 2002
    Messages:
    1,126
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    51
    Location:
    Centre of the Universe
    Ratings:
    +44
    Steve,

    Cheers, but yes I have set it up to do this.

    I have spoken to Denon and I am waiting to here what they come back with.
    Hopefully some good news. Just need to wait.

    If I get chance this weekend will possibly re-intialise the player see if this has any effect.

    eatstatic
     
  10. steve1056

    steve1056
    Active Member

    Joined:
    Apr 20, 2002
    Messages:
    374
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Location:
    Reading
    Ratings:
    +5
    OK -- it was just a thought. BTW, I have a 2200 with the latest firmware and multi-region as set up by Denon UK. No problems at all playing SACD's.
     
  11. sohe68

    sohe68
    Standard Member

    Joined:
    Jun 9, 2004
    Messages:
    35
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    11
    Location:
    Stockholm
    Ratings:
    +4
    No problems, whatsoever with any format on my 2900.

    I have:

    DRV 030827
    B/E 6237W
    PANEL 0042-F

    /Ola
     
  12. eatstatic

    eatstatic
    Active Member

    Joined:
    Oct 22, 2002
    Messages:
    1,126
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    51
    Location:
    Centre of the Universe
    Ratings:
    +44
    Just to put things in order.

    Having tried everything I could think of, I contacted Denon who agreed to take back the unit for repairs.

    The firmware was/is not at fault but the unit itself (carriage/laser pick-up assembly to be precise).

    Although Denon did have the unit just short of a month :thumbsdow the player is now functioning correctly .....so far (with another years guarantee of the repair work). :smashin:

    Firmware/Drive when sent in for repair:-

    DRV 030827
    B/E 6237W
    PANEL 0043-F

    Now:-

    DRV 030227
    B/E 6237W
    PANEL 0043-F

    So that seems to be that for the moment.

    eatstatic.
     

Share This Page

Loading...