Home Entertainment & Technology Resource

  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Windows 7 - Annoying UK / US Language problem. UK spelling doesn't work.

Discussion in 'Computer Software & Operating Systems' started by Master Yoda, May 5, 2010.

  1. Master Yoda

    Master Yoda Member

    Joined:
    Jan 26, 2007
    Messages:
    626
    Trophy Points:
    31
    Ratings:
    +41
    Hoping someone can shed some light on this...

    I have Windows 7 Ultimate with all the updates installed. The language installed and setup is for the UK - UK English (I have nothing set to US language or spelling in any of the settings anywhere). Despite this, everything in Windows (whether it be when I'm using email or word etc) keeps spelling everything to US and not UK english. This is actually extremely annoying as it keeps showing me that I've spelt things incorrectly when I haven't and it's messing my mind up. Only US words are in the dictionary and not the UK versions of the same words.

    This seems to be a large bug in Windows 7 and I don't know how to fix it... I don't even have US language installed as an option so why on earth is it using US spelling?? UK English / UK keyboard is all I have installed and is the default language selected.
    Last edited: May 5, 2010
  2. Curly99

    Curly99 Moderator

    Joined:
    Dec 29, 2006
    Messages:
    8,937
    Trophy Points:
    166
    Ratings:
    +2,053
    Are you sure that "Location" and "System Locale" are set to "United Kingdom" in the Region and Language settings? Can you change the default language in browser, office apps...etc.
  3. Master Yoda

    Master Yoda Member

    Joined:
    Jan 26, 2007
    Messages:
    626
    Trophy Points:
    31
    Ratings:
    +41
    The 'location' in Region and Language is set to 'UK' - I just double checked. Everything is on UK and UK English...

    There is no option to change the language in Word or other apps... I just had a look.

    This must be affecting loads of other people too??
    Last edited: May 5, 2010
  4. twoodley

    twoodley Member

    Joined:
    Feb 10, 2006
    Messages:
    269
    Trophy Points:
    31
    Ratings:
    +42
    Oh yes there is :facepalm:
    Which version of Office are you using?
  5. Curly99

    Curly99 Moderator

    Joined:
    Dec 29, 2006
    Messages:
    8,937
    Trophy Points:
    166
    Ratings:
    +2,053
    did a google for the problem and not a lot came up...probably need to find a windows guide to follow and change the setting to another language local (preferably one that is English based) reboot then change back to UK setting/locale...etc see if that works....doesn't windows use the IE or outlook dictionary as a default spell checker?
  6. Mr Incredible

    Mr Incredible Well-Known Member

    Joined:
    Dec 2, 2003
    Messages:
    20,767
    Trophy Points:
    171
    Ratings:
    +8,242
  7. Master Yoda

    Master Yoda Member

    Joined:
    Jan 26, 2007
    Messages:
    626
    Trophy Points:
    31
    Ratings:
    +41
    Thanks for the links - I managed to get UK english working in Word using your link for Word 2003 (I'm using Office XP). It only worked for me after trying it several times. :thumbsup:

    After doing a bit more messing around with Windows Live mail, I also managed to get that to work. I found it had UK english installed, but for some reason wasn't defaulting to it (just like Word).

    I think this is a bit odd with Windows 7 - With Windows XP, if you set the language in the control panel, everything then follows suit (which is what you would expect). It appears that setting the language to UK English and the location to UK in Windows 7 control panel doesn't appear to do anything, as every application still defaults to US English (even though US english isn't even installed on my computer according to the Windows 7 control panel??).

    Anyway - thanks for the responses guys. Just glad it's now sorted. ;)
    Last edited: May 6, 2010

Share This Page