1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Whatsapp Push Notifications on iPhone 5 not working?

Discussion in 'iPhone Apps' started by NightHawk, Oct 3, 2012.

  1. NightHawk

    NightHawk Active Member

    Joined:
    Apr 4, 2007
    Messages:
    3,017
    Trophy Points:
    106
    Ratings:
    +352
    Been having trouble using Whatsapp.

    Previously used Whatsapp on BlackBerry without any problems but since using on the iPhone I don't get notified on new messages when connected via wifi. It always notifies when the app is open but I don't want Whatsapp draining the battery keeping it open all the time. 3G is more reliable in letting me know when I receive messages even when the app in closed but even then, sometimes it's delayed by 5 mins or more which can be frustrating.

    Awaiting a reply to my tweet sent to Whatsapp earlier on in the week about it but thinking it might be an iPhone/iOS problem.

    Anyone else having the same issues?
  2. bigfish

    bigfish Member

    Joined:
    Jan 15, 2006
    Messages:
    601
    Trophy Points:
    28
    Ratings:
    +30
    Mine works perfectly fine .
  3. NightHawk

    NightHawk Active Member

    Joined:
    Apr 4, 2007
    Messages:
    3,017
    Trophy Points:
    106
    Ratings:
    +352
    How often do you fetch new data in the mail, contacts calendars section of settings? I have set it at every 15 mins and it seems to have improved things.
    Last edited: Oct 6, 2012
  4. bigfish

    bigfish Member

    Joined:
    Jan 15, 2006
    Messages:
    601
    Trophy Points:
    28
    Ratings:
    +30
    I have it on 15m but all my mail accounts are push and whatsapp is also push so this setting is for fetching data that doesn't support push so it should not make a difference. Maybe try reinstalling it ?

    I just leave my whatsapp in the "taskbar" so it's minimised in a "paused" state. Also guessing you haven't accidentally disabled alerts in the whatsapp settings?
    Last edited: Oct 7, 2012
  5. NightHawk

    NightHawk Active Member

    Joined:
    Apr 4, 2007
    Messages:
    3,017
    Trophy Points:
    106
    Ratings:
    +352
    Sorry I realised after that whatsapp uses push not fetch.

    I think I have dodgy wifi performance on my iPhone. I only say this as the wifi symbol will not show up unless I unlock the phone. Once unlocked the wifi reconnects and then whatsapp messages come through. It does this both at work and at home.

    I've got an appointment at the Genius Bar Wednesday. Will explain the problem to them then. If I get a new iPhone5 it will be my 3rd one! :(
  6. bigfish

    bigfish Member

    Joined:
    Jan 15, 2006
    Messages:
    601
    Trophy Points:
    28
    Ratings:
    +30
    By the way when your phone is in sleep mode it's normal the wifi should cut off and revert to mobile data to save battery life and then reconnect when unlocked. Unless mobile data is turned off apparently then it stays active but can't confirm.
  7. NightHawk

    NightHawk Active Member

    Joined:
    Apr 4, 2007
    Messages:
    3,017
    Trophy Points:
    106
    Ratings:
    +352
    I always turn Mobile Data off when connected via wifi as it sometimes uses the 3G connection to download stuff using your mobile data allowance instead of just using the wifi connection.

    I don't think my wifi connection stays active the way 3G does in sleep mode.
  8. thestig230

    thestig230 Member

    Joined:
    Jul 28, 2011
    Messages:
    837
    Trophy Points:
    46
    Ratings:
    +106
    This post (11) https://discussions.apple.com/thread/4345149?start=0&tstart=0 suggests leaving the phone plugged into a charger to keep wi-fi connected when the phone goes to sleep.

    Not the best of fixes, but might solve your problem for now until apple adds another setting to allow you to decide whether you want to stay connect to wi-fi or not.
    • Thanks Thanks x 1
    Last edited: Oct 8, 2012

Share This Page