1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SPDIF DVD Playback Helicopter Chopping Noise

Discussion in 'Home Entertainment Computers' started by bigee1212, Jan 12, 2010.

  1. bigee1212

    bigee1212 Member

    Joined:
    Jan 12, 2010
    Messages:
    3
    Trophy Points:
    1
    Ratings:
    +0
    Hey guys,

    Need some help with a problem I am having. Currently running on a built computer with an ATI 4670 and an Audigy 4 Pro (I know creative :( but i had it from an older computer)


    I am not outputting sound via the motherboard or the hdmi out. I am using the optical out from the creative sound card. I have to use this because of the mixer i have attached to the card for a couple of mics i have attached (karaoke).

    Anyway. When I play a .avi file with AC3 audio stream. I would get this chopping noise (via Windows media player). Like a helicopter with its blades. This does not happen in VLC or GOM. Another thing to note is that when trying to adjust the volume via windows (speaker icon or volume control in WMP), the sound persists. the volume only changes by adjusting it on the receiver (Denon 3808ci).

    I know it was probably a filter problem. I have no other codecs installed expect for mkv playback via GOM. So i decided to install the AC3 Filter. This immediately fixed my problems with the .avi files. But playing dvds through windows media player the problem persists!!!






    a few things to note. idk how to get spdif passthrough to work. because for the audigy properties i can either choose:

    Use external Decoder (SPDIF passthrough)
    Use internal Decoder

    selecting either of these, the sound problem is the same. there is also an spdif i/o tab


    Default
    SPDIF in-decode
    SPDIF bypass (red light turns off if i pick this)


    And to top it off I dont know what to pick in the AC3 filter configuration.
    If "Use SPDIF' is UNCHECKED, then sound will work normal in .avi but not in dvds. If i CHECK "USE SPDIF" then no sound at all comes from the .avi or the dvd (not even the chopping nosie)


    i am trying to be as explicit as possible with my problem.

    Running Windows 7 x64.

    Sound file attached (helicopter noise!!)


    Download Audio Static.mp3, upload your files and earn money.






    I know someone has to know about this stuff. Please help!!!! :lease:


    thanks!!!












    PS: IN total media theater 3, the dvd files work fine (dont know about spdif passthrough but at least they play!!), but my dad wants to use WMP!!! i dont know why, but i think it has to do with the fact that he wants to use windows media center. i havent tested this in windows media center. i would imagine it uses the same stuff that WMP uses...






    also i read somewhere replacing msmpeg2adec.dll with the one from vista sometimes cures the problem, tried it. no avail.


    its a long post thanks for looking.
  2. bigee1212

    bigee1212 Member

    Joined:
    Jan 12, 2010
    Messages:
    3
    Trophy Points:
    1
    Ratings:
    +0
    the fact that the chopping volume can only be adjusted via the receiver (3808ci Denon) leads me to believe its a problem with the receiver... but i really dont know where to look in the menus or anything! any help would be appreciated.
  3. bigee1212

    bigee1212 Member

    Joined:
    Jan 12, 2010
    Messages:
    3
    Trophy Points:
    1
    Ratings:
    +0
    bump

Share This Page